aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2012-10-12 15:32:08 +0000
committergrothoff <grothoff@140774ce-b5e7-0310-ab8b-a85725594a96>2012-10-12 15:32:08 +0000
commit35809889891e05a356d5ed46c635d205de0e7ca1 (patch)
tree3eaf2f4c2f1272e817a4d23d1b642a16ae0bce05 /configure.ac
parent24cce0c57affba1eb8db379dd7b6b6ff7456abc2 (diff)
-fix for #688590: allow user to specify how to install nsslibs
git-svn-id: https://gnunet.org/svn/gnunet@24295 140774ce-b5e7-0310-ab8b-a85725594a96
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c1d463a263..0bedbaca95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -812,6 +812,42 @@ AC_ARG_WITH(sudo,
AC_SUBST(SUDO_BINARY)
AM_CONDITIONAL([HAVE_SUDO], [test "x$SUDO_BINARY" != "x" -o -w /])
+
+# test for nssdir
+AC_MSG_CHECKING(with nssdir)
+AC_ARG_WITH(nssdir,
+ [ --with-nssdir=PATH where to install NSS plugins],
+ [AC_MSG_RESULT("$with_nssdir")
+ case $with_nssdir in
+ no)
+ NSS_DIR=
+ install_nss=0
+ ;;
+ yes)
+ NSS_DIR="/lib"
+ install_nss=1
+ ;;
+ *)
+ NSS_DIR=$with_nssdir
+ install_nss=1
+ ;;
+ esac
+ ],
+ [
+ if test "x$SUDO_BINARY" != "x" -o -w /
+ then
+ NSS_DIR="/lib"
+ install_nss=1
+ AC_MSG_RESULT([yes, to /lib])
+ else
+ NSS_DIR=
+ install_nss=0
+ AC_MSG_RESULT([no])
+ fi
+ ])
+AC_SUBST(NSS_DIR)
+AM_CONDITIONAL([INSTALL_NSS], [test "x$install_nss" != "x0"])
+
# test for gnunetdns group name
GNUNETDNS_GROUP=gnunetdns
AC_MSG_CHECKING(for gnunetdns group name)