aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwachs <wachs@140774ce-b5e7-0310-ab8b-a85725594a96>2012-08-22 08:13:47 +0000
committerwachs <wachs@140774ce-b5e7-0310-ab8b-a85725594a96>2012-08-22 08:13:47 +0000
commit4eccf3bc7d3a1980c214e5dc46fa10965424ab53 (patch)
tree7ede69ddb6952e427419c147beb59f07933a3ca2 /configure.ac
parent31439ab6538ef9e7663749d9b95e32877121a4cc (diff)
libcurl check
git-svn-id: https://gnunet.org/svn/gnunet@23353 140774ce-b5e7-0310-ab8b-a85725594a96
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 714610a019..78f7be9ab8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -326,7 +326,14 @@ AC_LANG_POP(C)
fi # $build = $target
# libcurl
-LIBCURL_CHECK_CONFIG(,7.21.3,,AC_MSG_ERROR([GNUnet requires libcurl >= 7.21.3]))
+LIBCURL_CHECK_CONFIG(,7.21.3,curl=1,curl=0)
+if test "$curl" = 1
+then
+ AM_CONDITIONAL(HAVE_LIBCURL, true)
+ AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])
+else
+ AM_CONDITIONAL(HAVE_LIBCURL, false)
+fi
# restore LIBS
LIBS=$SAVE_LIBS
@@ -1123,6 +1130,12 @@ then
AC_MSG_NOTICE([NOTICE: sqlite not found. sqLite support will not be compiled.])
fi
+# libcurl
+if test "x$curl" = "x0"
+then
+ AC_MSG_NOTICE([NOTICE: libcurl not found. http client support will not be compiled.])
+fi
+
#gnutls
if test x$gnutls != xtrue
then