aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNils Gillmann <ng0@n0.is>2018-03-31 11:07:50 +0000
committerNils Gillmann <ng0@n0.is>2018-03-31 11:07:50 +0000
commitb6cf770ab68030d2ba6d7c2c9ed0a5655de4f1d6 (patch)
treeb5e4e666e354c83844e20865958b986aac662f91 /Makefile.am
parentc60051643fe8bc3e6ec4dcc6dc28d1fc03bfe740 (diff)
Add condition to toplevel Makefile to support building just the documentation. Cornercase for special occasions.
Signed-off-by: Nils Gillmann <ng0@n0.is>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 6864b49561..45a693ac94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,16 @@
# This Makefile.am is in the public domain
AM_CPPFLAGS = -I$(top_srcdir)/src/include
-SUBDIRS = doc m4 src po pkgconfig
+if DOCUMENTATION_ONLY
+ SUBDIRS = doc
+else
+ SUBDIRS = doc m4 src po pkgconfig
+endif
if !TALER_ONLY
SUBDIRS += contrib
endif
-if DOCUMENTATION_ONLY
- SUBDIRS = doc
-endif
-
EXTRA_DIST = \
ABOUT-NLS \
config.rpath \