aboutsummaryrefslogtreecommitdiff
path: root/src/postgres/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/postgres/Makefile.am')
-rw-r--r--src/postgres/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/postgres/Makefile.am b/src/postgres/Makefile.am
new file mode 100644
index 0000000..0b3be5e
--- /dev/null
+++ b/src/postgres/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = -I$(top_srcdir)/src/include
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage
+endif
+
+lib_LTLIBRARIES = libgnunetpostgres.la
+
+libgnunetpostgres_la_SOURCES = \
+ postgres.c
+libgnunetpostgres_la_LIBADD = -lpq \
+ $(top_builddir)/src/util/libgnunetutil.la
+libgnunetpostgres_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) \
+ -version-info 0:0:0
+