aboutsummaryrefslogtreecommitdiff
path: root/src/mysql/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mysql/Makefile.am')
-rw-r--r--src/mysql/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/mysql/Makefile.am b/src/mysql/Makefile.am
new file mode 100644
index 0000000..1711e75
--- /dev/null
+++ b/src/mysql/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = -I$(top_srcdir)/src/include
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage
+endif
+
+lib_LTLIBRARIES = libgnunetmysql.la
+
+libgnunetmysql_la_SOURCES = \
+ mysql.c
+libgnunetmysql_la_LIBADD = -lmysqlclient \
+ $(top_builddir)/src/util/libgnunetutil.la
+libgnunetmysql_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) \
+ -version-info 0:0:0
+