aboutsummaryrefslogtreecommitdiff
path: root/src/mesh
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesh')
-rw-r--r--src/mesh/Makefile.am251
-rw-r--r--src/mesh/Makefile.in788
-rw-r--r--src/mesh/gnunet-mesh.c235
-rw-r--r--src/mesh/gnunet-service-mesh-new.c8483
-rw-r--r--src/mesh/gnunet-service-mesh.c5318
-rw-r--r--src/mesh/mesh.conf.in13
-rw-r--r--src/mesh/mesh.h247
-rw-r--r--src/mesh/mesh_api.c998
-rw-r--r--src/mesh/mesh_common.c250
-rw-r--r--src/mesh/mesh_protocol.h126
-rw-r--r--src/mesh/mesh_test_lib.c297
-rw-r--r--src/mesh/mesh_test_lib.h106
-rw-r--r--src/mesh/mesh_tunnel_tree.c121
-rw-r--r--src/mesh/mesh_tunnel_tree.h47
-rw-r--r--src/mesh/plugin_block_mesh.c205
-rw-r--r--src/mesh/test_mesh.conf20
-rw-r--r--src/mesh/test_mesh_2dtorus.c320
-rw-r--r--src/mesh/test_mesh_2dtorus.conf62
-rw-r--r--src/mesh/test_mesh_api.c104
-rw-r--r--src/mesh/test_mesh_local_1.c111
-rw-r--r--src/mesh/test_mesh_local_2.c109
-rw-r--r--src/mesh/test_mesh_local_traffic.c526
-rw-r--r--src/mesh/test_mesh_path.conf69
-rw-r--r--src/mesh/test_mesh_regex.c444
-rw-r--r--src/mesh/test_mesh_small.c987
-rw-r--r--src/mesh/test_mesh_small.conf63
-rw-r--r--src/mesh/test_mesh_tree_api.c67
27 files changed, 17909 insertions, 2458 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index ac38b0d..7d9a4da 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -11,53 +11,141 @@ endif
pkgcfgdir= $(pkgdatadir)/config.d/
+libexecdir= $(pkglibdir)/libexec/
+
pkgcfg_DATA = \
mesh.conf
+plugindir = $(libdir)/gnunet
+
AM_CLFAGS = -g
+libexec_PROGRAMS = \
+ gnunet-service-mesh gnunet-service-mesh-new
+
bin_PROGRAMS = \
- gnunet-service-mesh
+ gnunet-mesh
lib_LTLIBRARIES = \
libgnunetmesh.la
+plugin_LTLIBRARIES = \
+ libgnunet_plugin_block_mesh.la
+
+libgnunet_plugin_block_mesh_la_SOURCES = \
+ plugin_block_mesh.c
+libgnunet_plugin_block_mesh_la_LIBADD = \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+libgnunet_plugin_block_mesh_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+libgnunet_plugin_block_mesh_la_DEPENDENCIES = \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+libgnunetmesh_la_SOURCES = \
+ mesh_api.c mesh_common.c
+libgnunetmesh_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(XLIB) \
+ $(LTLIBINTL)
+libgnunetmesh_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) $(WINFLAGS) \
+ -version-info 2:1:1
+
gnunet_service_mesh_SOURCES = \
gnunet-service-mesh.c \
- mesh_tunnel_tree.c mesh_tunnel_tree.h
+ mesh_tunnel_tree.c mesh_tunnel_tree.h \
+ mesh_common.c
+gnunet_service_mesh_CFLAGS = $(AM_CFLAGS)
gnunet_service_mesh_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la\
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/core/libgnunetcore.la \
$(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/util/libgnunetutil.la
- gnunet_service_mesh_DEPENDENCIES = \
- $(top_builddir)/src/core/libgnunetcore.la\
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/regex/libgnunetregex.la
+gnunet_service_mesh_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/core/libgnunetcore.la \
$(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/regex/libgnunetregex.la
+if LINUX
+gnunet_service_mesh_LDFLAGS = -lrt
+endif
+
+gnunet_mesh_SOURCES = \
+ gnunet-mesh.c
+gnunet_mesh_LDADD = \
+ $(top_builddir)/src/mesh/libgnunetmesh.la \
$(top_builddir)/src/util/libgnunetutil.la
+gnunet_mesh_DEPENDENCIES = \
+ libgnunetmesh.la
-libgnunetmesh_la_SOURCES = \
- mesh_api.c mesh.h mesh_protocol.h
-libgnunetmesh_la_LIBADD = \
+gnunet_service_mesh_new_SOURCES = \
+ gnunet-service-mesh-new.c \
+ mesh_tunnel_tree.c \
+ mesh_common.c
+gnunet_service_mesh_new_CFLAGS = $(AM_CFLAGS)
+gnunet_service_mesh_new_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(XLIB)
-libgnunetmesh_la_LDFLAGS = \
- $(GN_LIB_LDFLAGS) $(WINFLAGS) \
- -version-info 1:0:0
+ $(top_builddir)/src/core/libgnunetcore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/regex/libgnunetregex.la
+gnunet_service_mesh_new_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/core/libgnunetcore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/regex/libgnunetregex.la
+if LINUX
+gnunet_service_mesh_new_LDFLAGS = -lrt
+endif
+
+
+noinst_LIBRARIES = libgnunetmeshtest.a
+
+libgnunetmeshtest_a_SOURCES = \
+ mesh_test_lib.c mesh_test_lib.h
+libgnunetmeshtest_a_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ $(top_builddir)/src/mesh/libgnunetmesh.la
+libgnunetmeshtest_a_DEPENDENCIES = \
+ libgnunetmesh.la
+
check_PROGRAMS = \
test_mesh_api \
test_mesh_tree_api \
test_mesh_local_1 \
test_mesh_local_2 \
+ test_mesh_local_traffic_fwd \
+ test_mesh_local_traffic_bck \
+ test_mesh_local_traffic_both \
test_mesh_2dtorus \
+ test_mesh_regex \
test_mesh_small_unicast \
test_mesh_small_multicast \
+ test_mesh_small_signal \
test_mesh_small_speed \
+ test_mesh_small_speed_nobuf \
+ test_mesh_small_speed_min \
+ test_mesh_small_speed_backwards \
+ test_mesh_small_speed_nobuf_backwards \
+ test_mesh_small_speed_min_backwards \
test_mesh_small_speed_ack
test_mesh_api_SOURCES = \
test_mesh_api.c
test_mesh_api_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/mesh/libgnunetmesh.la
test_mesh_api_DEPENDENCIES = \
libgnunetmesh.la \
@@ -67,7 +155,7 @@ test_mesh_tree_api_SOURCES = \
test_mesh_tree_api.c
test_mesh_tree_api_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/dht/libgnunetdht.la
+ $(top_builddir)/src/dht/libgnunetdht.la
test_mesh_tree_api_DEPENDENCIES = \
libgnunetmesh.la \
$(top_builddir)/src/dht/libgnunetdht.la
@@ -76,6 +164,7 @@ test_mesh_local_1_SOURCES = \
test_mesh_local_1.c
test_mesh_local_1_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/mesh/libgnunetmesh.la
test_mesh_local_1_DEPENDENCIES = \
libgnunetmesh.la
@@ -84,59 +173,129 @@ test_mesh_local_2_SOURCES = \
test_mesh_local_2.c
test_mesh_local_2_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
$(top_builddir)/src/mesh/libgnunetmesh.la
test_mesh_local_2_DEPENDENCIES = \
libgnunetmesh.la
+test_mesh_local_traffic_fwd_SOURCES = \
+ test_mesh_local_traffic.c
+test_mesh_local_traffic_fwd_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/mesh/libgnunetmesh.la
+test_mesh_local_traffic_fwd_DEPENDENCIES = \
+ libgnunetmesh.la
+
+test_mesh_local_traffic_bck_SOURCES = \
+ test_mesh_local_traffic.c
+test_mesh_local_traffic_bck_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/mesh/libgnunetmesh.la
+test_mesh_local_traffic_bck_DEPENDENCIES = \
+ libgnunetmesh.la
+
+test_mesh_local_traffic_both_SOURCES = \
+ test_mesh_local_traffic.c
+test_mesh_local_traffic_both_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/mesh/libgnunetmesh.la
+test_mesh_local_traffic_both_DEPENDENCIES = \
+ libgnunetmesh.la
+
+
+ld_mesh_test_lib = \
+ $(top_builddir)/src/mesh/libgnunetmeshtest.a \
+ $(top_builddir)/src/mesh/libgnunetmesh.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+dep_mesh_test_lib = \
+ libgnunetmeshtest.a \
+ libgnunetmesh.la
+
test_mesh_2dtorus_SOURCES = \
test_mesh_2dtorus.c
-test_mesh_2dtorus_LDADD = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la
+test_mesh_2dtorus_LDADD = $(ld_mesh_test_lib)
+test_mesh_2dtorus_DEPENDENCIES = $(dep_mesh_test_lib)
+
+test_mesh_regex_SOURCES = \
+ test_mesh_regex.c
+test_mesh_regex_LDADD = $(ld_mesh_test_lib)
+test_mesh_regex_DEPENDENCIES = $(dep_mesh_test_lib)
test_mesh_small_unicast_SOURCES = \
test_mesh_small.c
-test_mesh_small_unicast_LDADD = \
- $(top_builddir)/src/mesh/libgnunetmesh.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la
-test_mesh_small_unicast_DEPENDENCIES = \
- libgnunetmesh.la
+test_mesh_small_unicast_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_unicast_DEPENDENCIES = $(dep_mesh_test_lib)
test_mesh_small_multicast_SOURCES = \
test_mesh_small.c
-test_mesh_small_multicast_LDADD = \
- $(top_builddir)/src/mesh/libgnunetmesh.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la
-test_mesh_small_multicast_DEPENDENCIES = \
- libgnunetmesh.la
+test_mesh_small_multicast_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_multicast_DEPENDENCIES = $(dep_mesh_test_lib)
-test_mesh_small_speed_SOURCES = \
+test_mesh_small_signal_SOURCES = \
test_mesh_small.c
-test_mesh_small_speed_LDADD = \
- $(top_builddir)/src/mesh/libgnunetmesh.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la
-test_mesh_small_speed_DEPENDENCIES = \
- libgnunetmesh.la
+test_mesh_small_signal_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_signal_DEPENDENCIES = $(dep_mesh_test_lib)
test_mesh_small_speed_ack_SOURCES = \
test_mesh_small.c
-test_mesh_small_speed_ack_LDADD = \
- $(top_builddir)/src/mesh/libgnunetmesh.la \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la
-test_mesh_small_speed_ack_DEPENDENCIES = \
- libgnunetmesh.la
+test_mesh_small_speed_ack_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_speed_ack_DEPENDENCIES = $(dep_mesh_test_lib)
+
+test_mesh_small_speed_SOURCES = \
+ test_mesh_small.c
+test_mesh_small_speed_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_speed_DEPENDENCIES = $(dep_mesh_test_lib)
+
+test_mesh_small_speed_min_SOURCES = \
+ test_mesh_small.c
+test_mesh_small_speed_min_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_speed_min_DEPENDENCIES = $(dep_mesh_test_lib)
+
+test_mesh_small_speed_nobuf_SOURCES = \
+ test_mesh_small.c
+test_mesh_small_speed_nobuf_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_speed_nobuf_DEPENDENCIES = $(dep_mesh_test_lib)
+
+test_mesh_small_speed_backwards_SOURCES = \
+ test_mesh_small.c
+test_mesh_small_speed_backwards_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_speed_backwards_DEPENDENCIES = $(dep_mesh_test_lib)
+
+test_mesh_small_speed_min_backwards_SOURCES = \
+ test_mesh_small.c
+test_mesh_small_speed_min_backwards_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_speed_min_backwards_DEPENDENCIES = $(dep_mesh_test_lib)
+
+test_mesh_small_speed_nobuf_backwards_SOURCES = \
+ test_mesh_small.c
+test_mesh_small_speed_nobuf_backwards_LDADD = $(ld_mesh_test_lib)
+test_mesh_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh_test_lib)
+
if ENABLE_TEST_RUN
-TESTS = test_mesh_api test_mesh_tree_api test_mesh_local_1 test_mesh_local_2 \
- test_mesh_2dtorus test_mesh_small_unicast test_mesh_small_multicast
+TESTS = test_mesh_api \
+ test_mesh_tree_api \
+ test_mesh_local_1 test_mesh_local_2 \
+ test_mesh_local_traffic_fwd \
+ test_mesh_local_traffic_bck \
+ test_mesh_local_traffic_both \
+ test_mesh_2dtorus test_mesh_regex \
+ test_mesh_small_unicast test_mesh_small_multicast \
+ test_mesh_small_signal \
+ test_mesh_small_speed \
+ test_mesh_small_speed_min \
+ test_mesh_small_speed_nobuf \
+ test_mesh_small_speed_backwards \
+ test_mesh_small_speed_min_backwards
endif
EXTRA_DIST = \
+ mesh.h mesh_protocol.h \
test_mesh.conf \
test_mesh_2dtorus.conf \
- test_mesh_small.conf \
- test_mesh_path.conf
+ test_mesh_small.conf
diff --git a/src/mesh/Makefile.in b/src/mesh/Makefile.in
index 1504c4b..4c55099 100644
--- a/src/mesh/Makefile.in
+++ b/src/mesh/Makefile.in
@@ -1,9 +1,9 @@
-# Makefile.in generated by automake 1.11.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.6 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
-# Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -17,7 +17,25 @@
+
VPATH = @srcdir@
+am__make_dryrun = \
+ { \
+ am__dry=no; \
+ case $$MAKEFLAGS in \
+ *\\[\ \ ]*) \
+ echo 'am--echo: ; @echo "AM" OK' | $(MAKE) -f - 2>/dev/null \
+ | grep '^AM OK$$' >/dev/null || am__dry=yes;; \
+ *) \
+ for am__flg in $$MAKEFLAGS; do \
+ case $$am__flg in \
+ *=*|--*) ;; \
+ *n*) am__dry=yes; break;; \
+ esac; \
+ done;; \
+ esac; \
+ test $$am__dry = yes; \
+ }
pkgdatadir = $(datadir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
@@ -37,34 +55,56 @@ POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
target_triplet = @target@
-bin_PROGRAMS = gnunet-service-mesh$(EXEEXT)
+libexec_PROGRAMS = gnunet-service-mesh$(EXEEXT) \
+ gnunet-service-mesh-new$(EXEEXT)
+bin_PROGRAMS = gnunet-mesh$(EXEEXT)
check_PROGRAMS = test_mesh_api$(EXEEXT) test_mesh_tree_api$(EXEEXT) \
test_mesh_local_1$(EXEEXT) test_mesh_local_2$(EXEEXT) \
- test_mesh_2dtorus$(EXEEXT) test_mesh_small_unicast$(EXEEXT) \
+ test_mesh_local_traffic_fwd$(EXEEXT) \
+ test_mesh_local_traffic_bck$(EXEEXT) \
+ test_mesh_local_traffic_both$(EXEEXT) \
+ test_mesh_2dtorus$(EXEEXT) test_mesh_regex$(EXEEXT) \
+ test_mesh_small_unicast$(EXEEXT) \
test_mesh_small_multicast$(EXEEXT) \
- test_mesh_small_speed$(EXEEXT) \
+ test_mesh_small_signal$(EXEEXT) test_mesh_small_speed$(EXEEXT) \
+ test_mesh_small_speed_nobuf$(EXEEXT) \
+ test_mesh_small_speed_min$(EXEEXT) \
+ test_mesh_small_speed_backwards$(EXEEXT) \
+ test_mesh_small_speed_nobuf_backwards$(EXEEXT) \
+ test_mesh_small_speed_min_backwards$(EXEEXT) \
test_mesh_small_speed_ack$(EXEEXT)
@ENABLE_TEST_RUN_TRUE@TESTS = test_mesh_api$(EXEEXT) \
@ENABLE_TEST_RUN_TRUE@ test_mesh_tree_api$(EXEEXT) \
@ENABLE_TEST_RUN_TRUE@ test_mesh_local_1$(EXEEXT) \
@ENABLE_TEST_RUN_TRUE@ test_mesh_local_2$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_local_traffic_fwd$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_local_traffic_bck$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_local_traffic_both$(EXEEXT) \
@ENABLE_TEST_RUN_TRUE@ test_mesh_2dtorus$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_regex$(EXEEXT) \
@ENABLE_TEST_RUN_TRUE@ test_mesh_small_unicast$(EXEEXT) \
-@ENABLE_TEST_RUN_TRUE@ test_mesh_small_multicast$(EXEEXT)
+@ENABLE_TEST_RUN_TRUE@ test_mesh_small_multicast$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_small_signal$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_small_speed$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_small_speed_min$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_small_speed_nobuf$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_small_speed_backwards$(EXEEXT) \
+@ENABLE_TEST_RUN_TRUE@ test_mesh_small_speed_min_backwards$(EXEEXT)
subdir = src/mesh
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
$(srcdir)/mesh.conf.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/absolute-header.m4 \
$(top_srcdir)/m4/align.m4 $(top_srcdir)/m4/argz.m4 \
- $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/iconv.m4 \
- $(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
- $(top_srcdir)/m4/lib-prefix.m4 $(top_srcdir)/m4/libcurl.m4 \
- $(top_srcdir)/m4/libgcrypt.m4 $(top_srcdir)/m4/libtool.m4 \
- $(top_srcdir)/m4/libunistring.m4 $(top_srcdir)/m4/ltdl.m4 \
- $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
- $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
- $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
+ $(top_srcdir)/m4/gettext.m4 $(top_srcdir)/m4/glib-2.0.m4 \
+ $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
+ $(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
+ $(top_srcdir)/m4/libcurl.m4 $(top_srcdir)/m4/libgcrypt.m4 \
+ $(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/libunistring.m4 \
+ $(top_srcdir)/m4/ltdl.m4 $(top_srcdir)/m4/ltoptions.m4 \
+ $(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
+ $(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/m4/nls.m4 \
+ $(top_srcdir)/m4/pkg.m4 $(top_srcdir)/m4/po.m4 \
$(top_srcdir)/m4/progtest.m4 $(top_srcdir)/acinclude.m4 \
$(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
@@ -73,6 +113,17 @@ mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/gnunet_config.h
CONFIG_CLEAN_FILES = mesh.conf
CONFIG_CLEAN_VPATH_FILES =
+LIBRARIES = $(noinst_LIBRARIES)
+ARFLAGS = cru
+AM_V_AR = $(am__v_AR_@AM_V@)
+am__v_AR_ = $(am__v_AR_@AM_DEFAULT_V@)
+am__v_AR_0 = @echo " AR " $@;
+AM_V_at = $(am__v_at_@AM_V@)
+am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
+am__v_at_0 = @
+libgnunetmeshtest_a_AR = $(AR) $(ARFLAGS)
+am_libgnunetmeshtest_a_OBJECTS = mesh_test_lib.$(OBJEXT)
+libgnunetmeshtest_a_OBJECTS = $(am_libgnunetmeshtest_a_OBJECTS)
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
am__vpath_adj = case $$p in \
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
@@ -94,45 +145,108 @@ am__nobase_list = $(am__nobase_strip_setup); \
am__base_list = \
sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
-am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" \
+am__uninstall_files_from_dir = { \
+ test -z "$$files" \
+ || { test ! -d "$$dir" && test ! -f "$$dir" && test ! -r "$$dir"; } \
+ || { echo " ( cd '$$dir' && rm -f" $$files ")"; \
+ $(am__cd) "$$dir" && rm -f $$files; }; \
+ }
+am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(plugindir)" \
+ "$(DESTDIR)$(bindir)" "$(DESTDIR)$(libexecdir)" \
"$(DESTDIR)$(pkgcfgdir)"
-LTLIBRARIES = $(lib_LTLIBRARIES)
+LTLIBRARIES = $(lib_LTLIBRARIES) $(plugin_LTLIBRARIES)
+am_libgnunet_plugin_block_mesh_la_OBJECTS = plugin_block_mesh.lo
+libgnunet_plugin_block_mesh_la_OBJECTS = \
+ $(am_libgnunet_plugin_block_mesh_la_OBJECTS)
+AM_V_lt = $(am__v_lt_@AM_V@)
+am__v_lt_ = $(am__v_lt_@AM_DEFAULT_V@)
+am__v_lt_0 = --silent
+libgnunet_plugin_block_mesh_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
+ $(AM_CFLAGS) $(CFLAGS) \
+ $(libgnunet_plugin_block_mesh_la_LDFLAGS) $(LDFLAGS) -o $@
am__DEPENDENCIES_1 =
libgnunetmesh_la_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(am__DEPENDENCIES_1)
-am_libgnunetmesh_la_OBJECTS = mesh_api.lo
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+am_libgnunetmesh_la_OBJECTS = mesh_api.lo mesh_common.lo
libgnunetmesh_la_OBJECTS = $(am_libgnunetmesh_la_OBJECTS)
-AM_V_lt = $(am__v_lt_$(V))
-am__v_lt_ = $(am__v_lt_$(AM_DEFAULT_VERBOSITY))
-am__v_lt_0 = --silent
libgnunetmesh_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
$(AM_CFLAGS) $(CFLAGS) $(libgnunetmesh_la_LDFLAGS) $(LDFLAGS) \
-o $@
-PROGRAMS = $(bin_PROGRAMS)
-am_gnunet_service_mesh_OBJECTS = gnunet-service-mesh.$(OBJEXT) \
- mesh_tunnel_tree.$(OBJEXT)
+PROGRAMS = $(bin_PROGRAMS) $(libexec_PROGRAMS)
+am_gnunet_mesh_OBJECTS = gnunet-mesh.$(OBJEXT)
+gnunet_mesh_OBJECTS = $(am_gnunet_mesh_OBJECTS)
+am_gnunet_service_mesh_OBJECTS = \
+ gnunet_service_mesh-gnunet-service-mesh.$(OBJEXT) \
+ gnunet_service_mesh-mesh_tunnel_tree.$(OBJEXT) \
+ gnunet_service_mesh-mesh_common.$(OBJEXT)
gnunet_service_mesh_OBJECTS = $(am_gnunet_service_mesh_OBJECTS)
+gnunet_service_mesh_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
+ $(gnunet_service_mesh_CFLAGS) $(CFLAGS) \
+ $(gnunet_service_mesh_LDFLAGS) $(LDFLAGS) -o $@
+am_gnunet_service_mesh_new_OBJECTS = \
+ gnunet_service_mesh_new-gnunet-service-mesh-new.$(OBJEXT) \
+ gnunet_service_mesh_new-mesh_tunnel_tree.$(OBJEXT) \
+ gnunet_service_mesh_new-mesh_common.$(OBJEXT)
+gnunet_service_mesh_new_OBJECTS = \
+ $(am_gnunet_service_mesh_new_OBJECTS)
+gnunet_service_mesh_new_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
+ $(gnunet_service_mesh_new_CFLAGS) $(CFLAGS) \
+ $(gnunet_service_mesh_new_LDFLAGS) $(LDFLAGS) -o $@
am_test_mesh_2dtorus_OBJECTS = test_mesh_2dtorus.$(OBJEXT)
test_mesh_2dtorus_OBJECTS = $(am_test_mesh_2dtorus_OBJECTS)
-test_mesh_2dtorus_DEPENDENCIES = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la
am_test_mesh_api_OBJECTS = test_mesh_api.$(OBJEXT)
test_mesh_api_OBJECTS = $(am_test_mesh_api_OBJECTS)
am_test_mesh_local_1_OBJECTS = test_mesh_local_1.$(OBJEXT)
test_mesh_local_1_OBJECTS = $(am_test_mesh_local_1_OBJECTS)
am_test_mesh_local_2_OBJECTS = test_mesh_local_2.$(OBJEXT)
test_mesh_local_2_OBJECTS = $(am_test_mesh_local_2_OBJECTS)
+am_test_mesh_local_traffic_bck_OBJECTS = \
+ test_mesh_local_traffic.$(OBJEXT)
+test_mesh_local_traffic_bck_OBJECTS = \
+ $(am_test_mesh_local_traffic_bck_OBJECTS)
+am_test_mesh_local_traffic_both_OBJECTS = \
+ test_mesh_local_traffic.$(OBJEXT)
+test_mesh_local_traffic_both_OBJECTS = \
+ $(am_test_mesh_local_traffic_both_OBJECTS)
+am_test_mesh_local_traffic_fwd_OBJECTS = \
+ test_mesh_local_traffic.$(OBJEXT)
+test_mesh_local_traffic_fwd_OBJECTS = \
+ $(am_test_mesh_local_traffic_fwd_OBJECTS)
+am_test_mesh_regex_OBJECTS = test_mesh_regex.$(OBJEXT)
+test_mesh_regex_OBJECTS = $(am_test_mesh_regex_OBJECTS)
am_test_mesh_small_multicast_OBJECTS = test_mesh_small.$(OBJEXT)
test_mesh_small_multicast_OBJECTS = \
$(am_test_mesh_small_multicast_OBJECTS)
+am_test_mesh_small_signal_OBJECTS = test_mesh_small.$(OBJEXT)
+test_mesh_small_signal_OBJECTS = $(am_test_mesh_small_signal_OBJECTS)
am_test_mesh_small_speed_OBJECTS = test_mesh_small.$(OBJEXT)
test_mesh_small_speed_OBJECTS = $(am_test_mesh_small_speed_OBJECTS)
am_test_mesh_small_speed_ack_OBJECTS = test_mesh_small.$(OBJEXT)
test_mesh_small_speed_ack_OBJECTS = \
$(am_test_mesh_small_speed_ack_OBJECTS)
+am_test_mesh_small_speed_backwards_OBJECTS = \
+ test_mesh_small.$(OBJEXT)
+test_mesh_small_speed_backwards_OBJECTS = \
+ $(am_test_mesh_small_speed_backwards_OBJECTS)
+am_test_mesh_small_speed_min_OBJECTS = test_mesh_small.$(OBJEXT)
+test_mesh_small_speed_min_OBJECTS = \
+ $(am_test_mesh_small_speed_min_OBJECTS)
+am_test_mesh_small_speed_min_backwards_OBJECTS = \
+ test_mesh_small.$(OBJEXT)
+test_mesh_small_speed_min_backwards_OBJECTS = \
+ $(am_test_mesh_small_speed_min_backwards_OBJECTS)
+am_test_mesh_small_speed_nobuf_OBJECTS = test_mesh_small.$(OBJEXT)
+test_mesh_small_speed_nobuf_OBJECTS = \
+ $(am_test_mesh_small_speed_nobuf_OBJECTS)
+am_test_mesh_small_speed_nobuf_backwards_OBJECTS = \
+ test_mesh_small.$(OBJEXT)
+test_mesh_small_speed_nobuf_backwards_OBJECTS = \
+ $(am_test_mesh_small_speed_nobuf_backwards_OBJECTS)
am_test_mesh_small_unicast_OBJECTS = test_mesh_small.$(OBJEXT)
test_mesh_small_unicast_OBJECTS = \
$(am_test_mesh_small_unicast_OBJECTS)
@@ -148,39 +262,68 @@ LTCOMPILE = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) \
$(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
$(AM_CFLAGS) $(CFLAGS)
-AM_V_CC = $(am__v_CC_$(V))
-am__v_CC_ = $(am__v_CC_$(AM_DEFAULT_VERBOSITY))
+AM_V_CC = $(am__v_CC_@AM_V@)
+am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
am__v_CC_0 = @echo " CC " $@;
-AM_V_at = $(am__v_at_$(V))
-am__v_at_ = $(am__v_at_$(AM_DEFAULT_VERBOSITY))
-am__v_at_0 = @
CCLD = $(CC)
LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
-AM_V_CCLD = $(am__v_CCLD_$(V))
-am__v_CCLD_ = $(am__v_CCLD_$(AM_DEFAULT_VERBOSITY))
+AM_V_CCLD = $(am__v_CCLD_@AM_V@)
+am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
am__v_CCLD_0 = @echo " CCLD " $@;
-AM_V_GEN = $(am__v_GEN_$(V))
-am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
+AM_V_GEN = $(am__v_GEN_@AM_V@)
+am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
am__v_GEN_0 = @echo " GEN " $@;
-SOURCES = $(libgnunetmesh_la_SOURCES) $(gnunet_service_mesh_SOURCES) \
+SOURCES = $(libgnunetmeshtest_a_SOURCES) \
+ $(libgnunet_plugin_block_mesh_la_SOURCES) \
+ $(libgnunetmesh_la_SOURCES) $(gnunet_mesh_SOURCES) \
+ $(gnunet_service_mesh_SOURCES) \
+ $(gnunet_service_mesh_new_SOURCES) \
$(test_mesh_2dtorus_SOURCES) $(test_mesh_api_SOURCES) \
$(test_mesh_local_1_SOURCES) $(test_mesh_local_2_SOURCES) \
+ $(test_mesh_local_traffic_bck_SOURCES) \
+ $(test_mesh_local_traffic_both_SOURCES) \
+ $(test_mesh_local_traffic_fwd_SOURCES) \
+ $(test_mesh_regex_SOURCES) \
$(test_mesh_small_multicast_SOURCES) \
+ $(test_mesh_small_signal_SOURCES) \
$(test_mesh_small_speed_SOURCES) \
$(test_mesh_small_speed_ack_SOURCES) \
+ $(test_mesh_small_speed_backwards_SOURCES) \
+ $(test_mesh_small_speed_min_SOURCES) \
+ $(test_mesh_small_speed_min_backwards_SOURCES) \
+ $(test_mesh_small_speed_nobuf_SOURCES) \
+ $(test_mesh_small_speed_nobuf_backwards_SOURCES) \
$(test_mesh_small_unicast_SOURCES) \
$(test_mesh_tree_api_SOURCES)
-DIST_SOURCES = $(libgnunetmesh_la_SOURCES) \
- $(gnunet_service_mesh_SOURCES) $(test_mesh_2dtorus_SOURCES) \
- $(test_mesh_api_SOURCES) $(test_mesh_local_1_SOURCES) \
- $(test_mesh_local_2_SOURCES) \
+DIST_SOURCES = $(libgnunetmeshtest_a_SOURCES) \
+ $(libgnunet_plugin_block_mesh_la_SOURCES) \
+ $(libgnunetmesh_la_SOURCES) $(gnunet_mesh_SOURCES) \
+ $(gnunet_service_mesh_SOURCES) \
+ $(gnunet_service_mesh_new_SOURCES) \
+ $(test_mesh_2dtorus_SOURCES) $(test_mesh_api_SOURCES) \
+ $(test_mesh_local_1_SOURCES) $(test_mesh_local_2_SOURCES) \
+ $(test_mesh_local_traffic_bck_SOURCES) \
+ $(test_mesh_local_traffic_both_SOURCES) \
+ $(test_mesh_local_traffic_fwd_SOURCES) \
+ $(test_mesh_regex_SOURCES) \
$(test_mesh_small_multicast_SOURCES) \
+ $(test_mesh_small_signal_SOURCES) \
$(test_mesh_small_speed_SOURCES) \
$(test_mesh_small_speed_ack_SOURCES) \
+ $(test_mesh_small_speed_backwards_SOURCES) \
+ $(test_mesh_small_speed_min_SOURCES) \
+ $(test_mesh_small_speed_min_backwards_SOURCES) \
+ $(test_mesh_small_speed_nobuf_SOURCES) \
+ $(test_mesh_small_speed_nobuf_backwards_SOURCES) \
$(test_mesh_small_unicast_SOURCES) \
$(test_mesh_tree_api_SOURCES)
+am__can_run_installinfo = \
+ case $$AM_UPDATE_INFO_DIR in \
+ n|no|NO) false;; \
+ *) (install-info --version) >/dev/null 2>&1;; \
+ esac
DATA = $(pkgcfg_DATA)
ETAGS = etags
CTAGS = ctags
@@ -222,6 +365,10 @@ EXEEXT = @EXEEXT@
EXT_LIBS = @EXT_LIBS@
EXT_LIB_PATH = @EXT_LIB_PATH@
FGREP = @FGREP@
+GLIB_CFLAGS = @GLIB_CFLAGS@
+GLIB_GENMARSHAL = @GLIB_GENMARSHAL@
+GLIB_LIBS = @GLIB_LIBS@
+GLIB_MKENUMS = @GLIB_MKENUMS@
GMSGFMT = @GMSGFMT@
GMSGFMT_015 = @GMSGFMT_015@
GNUNETDNS_GROUP = @GNUNETDNS_GROUP@
@@ -232,6 +379,7 @@ GN_LIBINTL = @GN_LIBINTL@
GN_LIB_LDFLAGS = @GN_LIB_LDFLAGS@
GN_PLUGIN_LDFLAGS = @GN_PLUGIN_LDFLAGS@
GN_USER_HOME_DIR = @GN_USER_HOME_DIR@
+GOBJECT_QUERY = @GOBJECT_QUERY@
GREP = @GREP@
HAVE_LIBUNISTRING = @HAVE_LIBUNISTRING@
INCLTDL = @INCLTDL@
@@ -254,6 +402,8 @@ LIBCURL_CPPFLAGS = @LIBCURL_CPPFLAGS@
LIBGCRYPT_CFLAGS = @LIBGCRYPT_CFLAGS@
LIBGCRYPT_CONFIG = @LIBGCRYPT_CONFIG@
LIBGCRYPT_LIBS = @LIBGCRYPT_LIBS@
+LIBGTOP_CFLAGS = @LIBGTOP_CFLAGS@
+LIBGTOP_LIBS = @LIBGTOP_LIBS@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
LIBLTDL = @LIBLTDL@
@@ -275,6 +425,7 @@ LT_CONFIG_H = @LT_CONFIG_H@
LT_DLLOADERS = @LT_DLLOADERS@
LT_DLPREOPEN = @LT_DLPREOPEN@
MAKEINFO = @MAKEINFO@
+MANIFEST_TOOL = @MANIFEST_TOOL@
MKDIR_P = @MKDIR_P@
MONKEYPREFIX = @MONKEYPREFIX@
MSGFMT = @MSGFMT@
@@ -284,6 +435,7 @@ MYSQL_CPPFLAGS = @MYSQL_CPPFLAGS@
MYSQL_LDFLAGS = @MYSQL_LDFLAGS@
NM = @NM@
NMEDIT = @NMEDIT@
+NSS_DIR = @NSS_DIR@
OBJC = @OBJC@
OBJCDEPMODE = @OBJCDEPMODE@
OBJCFLAGS = @OBJCFLAGS@
@@ -299,6 +451,7 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
+PKG_CONFIG = @PKG_CONFIG@
POSTGRES_CPPFLAGS = @POSTGRES_CPPFLAGS@
POSTGRES_LDFLAGS = @POSTGRES_LDFLAGS@
POSUB = @POSUB@
@@ -330,6 +483,7 @@ abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
+ac_ct_AR = @ac_ct_AR@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
@@ -352,6 +506,7 @@ datarootdir = @datarootdir@
docdir = @docdir@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
+gitcommand = @gitcommand@
host = @host@
host_alias = @host_alias@
host_cpu = @host_cpu@
@@ -362,10 +517,9 @@ includedir = @includedir@
infodir = @infodir@
install_sh = @install_sh@
libdir = @libdir@
-libexecdir = @libexecdir@
+libexecdir = $(pkglibdir)/libexec/
localedir = @localedir@
localstatedir = @localstatedir@
-lt_ECHO = @lt_ECHO@
ltdl_LIBOBJS = @ltdl_LIBOBJS@
ltdl_LTLIBOBJS = @ltdl_LTLIBOBJS@
mandir = @mandir@
@@ -383,6 +537,7 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
srcdir = @srcdir@
subdirs = @subdirs@
+svnversioncommand = @svnversioncommand@
sys_symbol_underscore = @sys_symbol_underscore@
sysconfdir = @sysconfdir@
target = @target@
@@ -401,40 +556,114 @@ pkgcfgdir = $(pkgdatadir)/config.d/
pkgcfg_DATA = \
mesh.conf
+plugindir = $(libdir)/gnunet
AM_CLFAGS = -g
lib_LTLIBRARIES = \
libgnunetmesh.la
+plugin_LTLIBRARIES = \
+ libgnunet_plugin_block_mesh.la
+
+libgnunet_plugin_block_mesh_la_SOURCES = \
+ plugin_block_mesh.c
+
+libgnunet_plugin_block_mesh_la_LIBADD = \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+libgnunet_plugin_block_mesh_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+
+libgnunet_plugin_block_mesh_la_DEPENDENCIES = \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
+libgnunetmesh_la_SOURCES = \
+ mesh_api.c mesh_common.c
+
+libgnunetmesh_la_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(XLIB) \
+ $(LTLIBINTL)
+
+libgnunetmesh_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) $(WINFLAGS) \
+ -version-info 2:1:1
+
gnunet_service_mesh_SOURCES = \
gnunet-service-mesh.c \
- mesh_tunnel_tree.c mesh_tunnel_tree.h
+ mesh_tunnel_tree.c mesh_tunnel_tree.h \
+ mesh_common.c
+gnunet_service_mesh_CFLAGS = $(AM_CFLAGS)
gnunet_service_mesh_LDADD = \
- $(top_builddir)/src/core/libgnunetcore.la\
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/core/libgnunetcore.la \
$(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/util/libgnunetutil.la
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/regex/libgnunetregex.la
gnunet_service_mesh_DEPENDENCIES = \
- $(top_builddir)/src/core/libgnunetcore.la\
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/core/libgnunetcore.la \
$(top_builddir)/src/dht/libgnunetdht.la \