aboutsummaryrefslogtreecommitdiff
path: root/src/hello/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/hello/Makefile.am')
-rw-r--r--src/hello/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/hello/Makefile.am b/src/hello/Makefile.am
index 1788e8f..26aa6c7 100644
--- a/src/hello/Makefile.am
+++ b/src/hello/Makefile.am
@@ -19,6 +19,9 @@ libgnunethello_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) \
-version-info 0:0:0
+noinst_PROGRAMS = \
+ gnunet-hello
+
check_PROGRAMS = \
test_hello
@@ -32,3 +35,13 @@ test_hello_LDADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la
+
+gnunet_hello_SOURCES = \
+ gnunet-hello.c
+gnunet_hello_LDADD = \
+ $(top_builddir)/src/hello/libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+gnunet_hello_DEPENDENCIES = \
+ libgnunethello.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+