aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 0de739d..b916e4e 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -50,7 +50,7 @@ libgnunetfs_la_LIBADD = \
libgnunetfs_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) $(WINFLAGS) \
- -version-info 2:0:0
+ -version-info 2:1:0
libgnunetfstest_a_SOURCES = \
@@ -206,6 +206,7 @@ check_PROGRAMS = \
test_fs_publish \
test_fs_publish_persistence \
test_fs_search \
+ test_fs_search_probes \
test_fs_search_persistence \
test_fs_start_stop \
test_fs_test_lib \
@@ -225,6 +226,11 @@ check_SCRIPTS = \
test_gnunet_fs_ns.py
endif
+if ENABLE_MONKEY
+ TESTS_ENVIRONMENT = @MONKEYPREFIX@
+ AM_LDFLAGS = -no-install
+endif
+
if ENABLE_TEST_RUN
TESTS = \
@@ -239,6 +245,7 @@ TESTS = \
test_fs_publish \
test_fs_publish_persistence \
test_fs_search \
+ test_fs_search_probes \
test_fs_search_persistence \
test_fs_start_stop \
test_fs_unindex \
@@ -329,6 +336,11 @@ test_fs_search_SOURCES = \
test_fs_search_LDADD = $(top_builddir)/src/fs/libgnunetfs.la \
$(top_builddir)/src/util/libgnunetutil.la
+test_fs_search_probes_SOURCES = \
+ test_fs_search_probes.c
+test_fs_search_probes_LDADD = $(top_builddir)/src/fs/libgnunetfs.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
test_fs_search_persistence_SOURCES = \
test_fs_search_persistence.c
test_fs_search_persistence_LDADD = $(top_builddir)/src/fs/libgnunetfs.la \