aboutsummaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index ad9bddc..e95cbcf 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -20,7 +20,8 @@ lib_LTLIBRARIES = \
libgnunetcore_la_SOURCES = \
core_api.c core.h \
- core_api_iterate_peers.c
+ core_api_iterate_peers.c \
+ core_api_is_connected.c
libgnunetcore_la_LIBADD = \
$(top_builddir)/src/util/libgnunetutil.la \
$(GN_LIBINTL) $(XLIB)
@@ -31,7 +32,7 @@ libgnunetcore_la_LDFLAGS = \
bin_PROGRAMS = \
gnunet-service-core \
- gnunet-core-list-connections
+ gnunet-core
gnunet_service_core_SOURCES = \
gnunet-service-core.c gnunet-service-core.h \
@@ -49,14 +50,12 @@ gnunet_service_core_LDADD = \
$(GN_LIBINTL) -lz
-gnunet_core_list_connections_SOURCES = \
- gnunet-core-list-connections.c
-gnunet_core_list_connections_LDADD = \
+gnunet_core_SOURCES = \
+ gnunet-core.c
+gnunet_core_LDADD = \
$(top_builddir)/src/core/libgnunetcore.la \
- $(top_builddir)/src/transport/libgnunettransport.la \
- $(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/util/libgnunetutil.la
-gnunet_core_list_connections_DEPENDENCIES = \
+gnunet_core_DEPENDENCIES = \
libgnunetcore.la
check_PROGRAMS = \