aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
new file mode 100644
index 0000000..df6bdc2
--- /dev/null
+++ b/contrib/Makefile.am
@@ -0,0 +1,47 @@
+INCLUDES = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
+
+
+if !MINGW
+noinst_PROGRAMS = \
+ timeout_watchdog
+
+timeout_watchdog_SOURCES = \
+ timeout_watchdog.c
+endif
+
+noinst_SCRIPTS = \
+ gnunet_pyexpect.py \
+ gnunet_janitor.py
+
+dist_pkgdata_DATA = \
+ gnunet-logo-color.png
+
+EXTRA_DIST = \
+ coverage.sh \
+ hostlist.cgi \
+ hostlist.php \
+ report.sh \
+ testing_hostkeys.dat \
+ gnunet_pyexpect.py.in \
+ gnunet_janitor.py.in
+
+do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
+
+%.py: %.py.in Makefile
+ $(do_subst) < $< > $@
+ chmod +x $@
+
+# init_gnunet_redhat \
+# init_gnunet_ubuntu \
+# visualize_stats.sh \
+# gnmessage.sh \
+# junkinsert.sh \
+# junklookup.sh \
+# namespacehelper.sh
+
+
+check_PROGRAMS = \
+ test_gnunet_prefix
+
+test_gnunet_prefix_SOURCES = \
+ test_gnunet_prefix.c