aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..1c804cb
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,29 @@
+INCLUDES = -I$(top_srcdir)/src/include
+SUBDIRS = contrib doc m4 src po pkgconfig
+
+EXTRA_DIST = \
+ ABOUT-NLS \
+ config.rpath \
+ install-sh \
+ acinclude.m4
+
+gnunetincludedir = $(includedir)/gnunet
+gnunetinclude_HEADERS = gnunet_config.h
+
+docdir = $(datadir)/doc/gnunet/
+doc_DATA = COPYING
+
+ACLOCAL_AMFLAGS = -I m4
+
+ChangeLog:
+ if test -f $(top_srcdir)/.svn/entries; then \
+ svn log -v --xml -r HEAD:18409 | \
+ xsltproc --stringparam ignore-message-starting "-" \
+ --stringparam strip-prefix "gnunet" \
+ --stringparam include-rev "yes" $(top_srcdir)/contrib/svn2cl.xsl - > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+