aboutsummaryrefslogtreecommitdiff
path: root/src/stream/Makefile.am
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
committerBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
commit740b30688bd745a527f96f9116c19acb3480971a (patch)
tree2709a3f4dba11c174aa9e1ba3612e30c578e76a9 /src/stream/Makefile.am
parent2b81464a43485fcc8ce079fafdee7b7a171835f4 (diff)
Imported Upstream version 0.9.3upstream/0.9.3
Diffstat (limited to 'src/stream/Makefile.am')
-rw-r--r--src/stream/Makefile.am29
1 files changed, 19 insertions, 10 deletions
diff --git a/src/stream/Makefile.am b/src/stream/Makefile.am
index 385c0cf..8d74417 100644
--- a/src/stream/Makefile.am
+++ b/src/stream/Makefile.am
@@ -20,8 +20,9 @@ libgnunetstream_la_LDFLAGS = \
$(GN_LIB_LDFLAGS)
check_PROGRAMS = \
- test_stream_local
-# test_stream_halfclose
+ test-stream-2peers \
+ test-stream-2peers_halfclose \
+ test-stream-local
EXTRA_DIST = test_stream_local.conf
@@ -29,15 +30,23 @@ if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS)
endif
+test_stream_2peers_SOURCES = \
+ test_stream_2peers.c
+test_stream_2peers_LDADD = \
+ $(top_builddir)/src/stream/libgnunetstream.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_stream_2peers_halfclose_SOURCES = \
+ test_stream_2peers_halfclose.c
+test_stream_2peers_halfclose_LDADD = \
+ $(top_builddir)/src/stream/libgnunetstream.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
test_stream_local_SOURCES = \
test_stream_local.c
test_stream_local_LDADD = \
$(top_builddir)/src/stream/libgnunetstream.la \
- $(top_builddir)/src/util/libgnunetutil.la
-
-#test_stream_halfclose_SOURCES = \
-# test_stream_halfclose.c
-#test_stream_halfclose_LDADD = \
-# $(top_builddir)/src/stream/libgnunetstream.la \
-# $(top_builddir)/src/util/libgnunetutil.la
-
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testing/libgnunettesting.la \ No newline at end of file