aboutsummaryrefslogtreecommitdiff
path: root/src/statistics/Makefile.am
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
committerBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
commit740b30688bd745a527f96f9116c19acb3480971a (patch)
tree2709a3f4dba11c174aa9e1ba3612e30c578e76a9 /src/statistics/Makefile.am
parent2b81464a43485fcc8ce079fafdee7b7a171835f4 (diff)
Imported Upstream version 0.9.3upstream/0.9.3
Diffstat (limited to 'src/statistics/Makefile.am')
-rw-r--r--src/statistics/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/statistics/Makefile.am b/src/statistics/Makefile.am
index 2d1daf8..ddf5fda 100644
--- a/src/statistics/Makefile.am
+++ b/src/statistics/Makefile.am
@@ -23,7 +23,7 @@ libgnunetstatistics_la_LIBADD = \
$(GN_LIBINTL) $(XLIB)
libgnunetstatistics_la_LDFLAGS = \
$(GN_LIB_LDFLAGS) $(WINFLAGS) \
- -version-info 1:0:1
+ -version-info 1:1:1
bin_PROGRAMS = \
@@ -51,7 +51,8 @@ gnunet_service_statistics_DEPENDENCIES = \
check_PROGRAMS = \
test_statistics_api \
test_statistics_api_loop \
- test_statistics_api_watch
+ test_statistics_api_watch \
+ test_statistics_api_watch_zero_value
if ENABLE_TEST_RUN
TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
@@ -75,6 +76,12 @@ test_statistics_api_watch_LDADD = \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/util/libgnunetutil.la
+test_statistics_api_watch_zero_value_SOURCES = \
+ test_statistics_api_watch_zero_value.c
+test_statistics_api_watch_zero_value_LDADD = \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
check_SCRIPTS = \
test_gnunet_statistics.sh