aboutsummaryrefslogtreecommitdiff
path: root/src/postgres/Makefile.am
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
committerBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
commit740b30688bd745a527f96f9116c19acb3480971a (patch)
tree2709a3f4dba11c174aa9e1ba3612e30c578e76a9 /src/postgres/Makefile.am
parent2b81464a43485fcc8ce079fafdee7b7a171835f4 (diff)
Imported Upstream version 0.9.3upstream/0.9.3
Diffstat (limited to 'src/postgres/Makefile.am')
-rw-r--r--src/postgres/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/postgres/Makefile.am b/src/postgres/Makefile.am
new file mode 100644
index 0000000..0b3be5e
--- /dev/null
+++ b/src/postgres/Makefile.am
@@ -0,0 +1,20 @@
+INCLUDES = -I$(top_srcdir)/src/include
+
+if MINGW
+ WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
+endif
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage
+endif
+
+lib_LTLIBRARIES = libgnunetpostgres.la
+
+libgnunetpostgres_la_SOURCES = \
+ postgres.c
+libgnunetpostgres_la_LIBADD = -lpq \
+ $(top_builddir)/src/util/libgnunetutil.la
+libgnunetpostgres_la_LDFLAGS = \
+ $(GN_LIB_LDFLAGS) \
+ -version-info 0:0:0
+