aboutsummaryrefslogtreecommitdiff
path: root/src/integration-tests/Makefile.am
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
committerBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
commit740b30688bd745a527f96f9116c19acb3480971a (patch)
tree2709a3f4dba11c174aa9e1ba3612e30c578e76a9 /src/integration-tests/Makefile.am
parent2b81464a43485fcc8ce079fafdee7b7a171835f4 (diff)
Imported Upstream version 0.9.3upstream/0.9.3
Diffstat (limited to 'src/integration-tests/Makefile.am')
-rw-r--r--src/integration-tests/Makefile.am60
1 files changed, 56 insertions, 4 deletions
diff --git a/src/integration-tests/Makefile.am b/src/integration-tests/Makefile.am
index d948b3d..fb69e28 100644
--- a/src/integration-tests/Makefile.am
+++ b/src/integration-tests/Makefile.am
@@ -9,13 +9,17 @@ if USE_COVERAGE
XLIB = -lgcov
endif
-bin_PROGRAMS =
+#bin_PROGRAMS = \
+# connection_watchdog
-check_PROGRAMS =
+noinst_PROGRAMS = connection_watchdog
noinst_SCRIPTS = \
gnunet_testing.py \
- gnunet_pyexpect.py
+ gnunet_pyexpect.py \
+ test_integration_connection_values_tcp.py \
+ test_integration_connection_values_tcp_udp.py \
+ test_integration_connection_values_tcp_udp_http.py
if HAVE_PYTHON_PEXPECT
check_SCRIPTS = \
@@ -24,16 +28,28 @@ check_SCRIPTS = \
test_integration_bootstrap_and_connect_and_disconnect_nat.py \
test_integration_restart.py \
test_integration_clique.py \
- test_integration_clique_nat.py
+ test_integration_clique_nat.py \
+ test_integration_connect_on_restart.py
endif
# test_integration_disconnect.py
+check_PROGRAMS = \
+ test_connection_stability
+
if ENABLE_TEST_RUN
TESTS = \
$(check_SCRIPTS)
endif
+connection_watchdog_SOURCE = \
+ connection_watchdog.c
+connection_watchdog_LDADD = \
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/core/libgnunetcore.la \
+ $(top_builddir)/src/transport/libgnunettransport.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
%.py: %.py.in Makefile
@@ -81,13 +97,39 @@ test_integration_clique_nat.py: test_integration_clique_nat.py.in Makefile
$(do_subst) < $(srcdir)/test_integration_clique_nat.py.in > test_integration_clique_nat.py
chmod +x test_integration_clique_nat.py
+test_integration_connect_on_restart.py: test_integration_connect_on_restart.py.in Makefile
+ $(do_subst) < $(srcdir)/test_integration_connect_on_restart.py.in > test_integration_connect_on_restart.py
+ chmod +x test_integration_connect_on_restart.py
+
+test_integration_connection_values_tcp.py: test_integration_connection_values_tcp.py.in Makefile
+ $(do_subst) < $(srcdir)/test_integration_connection_values_tcp.py.in > test_integration_connection_values_tcp.py
+ chmod +x test_integration_connection_values_tcp.py
+
+test_integration_connection_values_tcp_udp.py: test_integration_connection_values_tcp_udp.py.in Makefile
+ $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp.py.in > test_integration_connection_values_tcp_udp.py
+ chmod +x test_integration_connection_values_tcp_udp.py
+
+test_integration_connection_values_tcp_udp_http.py: test_integration_connection_values_tcp_udp_http.py.in Makefile
+ $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp_http.py.in > test_integration_connection_values_tcp_udp_http.py
+ chmod +x test_integration_connection_values_tcp_udp_http.py
+
+test_connection_stability_SOURCES = \
+ test_connection_stability.c
+test_connection_stability_LDADD = \
+ $(top_builddir)/src/testing/libgnunettesting.la \
+ $(top_builddir)/src/util/libgnunetutil.la
+
EXTRA_DIST = \
gnunet_testing.py.in \
gnunet_pyexpect.py.in \
+ test_integration_connection_values_tcp.py.in \
+ test_integration_connection_values_tcp_udp.py.in \
+ test_integration_connection_values_tcp_udp_http.py.in \
test_integration_bootstrap_and_connect.py.in \
test_integration_bootstrap_and_connect_and_disconnect.py.in \
test_integration_bootstrap_and_connect_and_disconnect_nat.py.in \
+ test_integration_connect_on_restart.py.in \
test_integration_disconnect.py.in \
test_integration_restart.py.in \
test_integration_clique.py.in \
@@ -96,6 +138,16 @@ EXTRA_DIST = \
confs/c_nat_client.conf \
confs/c_no_nat_client_2.conf \
confs/c_no_nat_client.conf \
+ confs/c_normal_client_tcp.conf \
+ confs/c_normal_client_tcp_udp.conf \
+ confs/c_normal_client_tcp_udp_http.conf \
+ confs/c_no_nat_client_http.conf \
+ confs/c_no_nat_client_http_2.conf\
+ confs/c_no_nat_client_http.conf \
+ confs/c_no_nat_client_http_2.conf \
+ confs/c_no_nat_client_unix.conf \
+ confs/c_no_nat_client_unix_2.conf \
+ test_connection_stability.conf \
hostkeys/0000-hostkey \
hostkeys/0001-hostkey \
hostkeys/0002-hostkey \