aboutsummaryrefslogtreecommitdiff
path: root/src/gns
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
committerBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
commit740b30688bd745a527f96f9116c19acb3480971a (patch)
tree2709a3f4dba11c174aa9e1ba3612e30c578e76a9 /src/gns
parent2b81464a43485fcc8ce079fafdee7b7a171835f4 (diff)
Imported Upstream version 0.9.3upstream/0.9.3
Diffstat (limited to 'src/gns')
-rw-r--r--src/gns/Makefile.am260
-rw-r--r--src/gns/Makefile.in641
-rw-r--r--src/gns/gns.conf.in25
-rw-r--r--src/gns/gns.h125
-rw-r--r--src/gns/gns_api.c919
-rw-r--r--src/gns/gns_proxy_proto.h49
-rw-r--r--src/gns/gnunet-gns-fcfsd.c811
-rw-r--r--src/gns/gnunet-gns-proxy.c815
-rw-r--r--src/gns/gnunet-gns.c262
-rw-r--r--src/gns/gnunet-service-gns.c1781
-rw-r--r--src/gns/gnunet-service-gns_interceptor.c394
-rw-r--r--src/gns/gnunet-service-gns_interceptor.h23
-rw-r--r--src/gns/gnunet-service-gns_resolver.c2751
-rw-r--r--src/gns/gnunet-service-gns_resolver.h356
-rw-r--r--src/gns/namestore_stub_api.c438
-rw-r--r--src/gns/nss/Makefile.am59
-rw-r--r--src/gns/nss/Makefile.in769
-rw-r--r--src/gns/nss/map-file14
-rw-r--r--src/gns/nss/nss_gns.c264
-rw-r--r--src/gns/nss/nss_gns_query.c65
-rw-r--r--src/gns/nss/nss_gns_query.h66
-rw-r--r--src/gns/plugin_block_gns.c165
-rw-r--r--src/gns/test_gns_defaults.conf69
-rw-r--r--src/gns/test_gns_dht_default.conf94
-rw-r--r--src/gns/test_gns_dht_delegated_lookup.c411
-rw-r--r--src/gns/test_gns_dht_threepeer.c524
-rw-r--r--src/gns/test_gns_max_queries.c381
-rw-r--r--src/gns/test_gns_pseu_shorten.c643
-rw-r--r--src/gns/test_gns_simple_delegated_lookup.c355
-rw-r--r--src/gns/test_gns_simple_get_authority.c388
-rw-r--r--src/gns/test_gns_simple_lookup.c317
-rw-r--r--src/gns/test_gns_simple_lookup.conf112
-rw-r--r--src/gns/test_gns_simple_mx_lookup.c396
-rw-r--r--src/gns/test_gns_simple_shorten.c388
-rw-r--r--src/gns/test_gns_simple_zkey_lookup.c358
-rw-r--r--src/gns/test_gns_twopeer.c463
-rw-r--r--src/gns/test_gns_twopeer.conf80
-rwxr-xr-xsrc/gns/test_gnunet_gns.sh22
38 files changed, 13449 insertions, 2604 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index cc19939..10b9ff3 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -1,5 +1,11 @@
INCLUDES = -I$(top_srcdir)/src/include
+if HAVE_GLIBCNSS
+NSS_SUBDIR = nss
+endif
+
+SUBDIRS = . $(NSS_SUBDIR)
+
if MINGW
WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
endif
@@ -16,98 +22,272 @@ pkgcfg_DATA = \
gns.conf
lib_LTLIBRARIES = \
- libgnunetgns.la libgnunetnamestore.la
+ libgnunetgns.la
+
+if HAVE_MHD
+ DO_FCFSD=gnunet-gns-fcfsd
+ DO_PROXY=gnunet-gns-proxy
+endif
bin_PROGRAMS = \
- gnunet-service-gns
+ gnunet-service-gns \
+ $(DO_FCFSD) \
+ $(DO_PROXY) \
+ gnunet-gns
#noinst_PROGRAMS = \
# gnunet-gns-lookup
-check_SCRIPTS = \
- test_gnunet_gns.sh
-
check_PROGRAMS = \
- test_gns_twopeer
+ test_gns_simple_shorten \
+ test_gns_simple_get_authority \
+ test_gns_simple_lookup \
+ test_gns_simple_delegated_lookup \
+ test_gns_simple_mx_lookup \
+ test_gns_simple_zkey_lookup \
+ test_gns_dht_delegated_lookup \
+ test_gns_pseu_shorten \
+ test_gns_max_queries \
+ test_gns_dht_threepeer
+
+
+# test_gns_simple_lookup
+# test_gns_simple_delegated_lookup
+# test_gns_dht_delegated_lookup
plugin_LTLIBRARIES = \
libgnunet_plugin_block_gns.la
-test_gns_twopeer_SOURCES = \
- test_gns_twopeer.c
-test_gns_twopeer_LDADD = \
+test_gns_dht_threepeer_SOURCES = \
+ test_gns_dht_threepeer.c
+test_gns_dht_threepeer_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_dht_threepeer_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_lookup_SOURCES = \
+ test_gns_simple_lookup.c
+test_gns_simple_lookup_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
-test_gns_twopeer_DEPENDENCIES = \
+test_gns_simple_lookup_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
-#gnunet_gns_lookup_SOURCES = \
-# gnunet-gns-lookup.c
-#gnunet_gns_lookup_LDADD = \
-# $(top_builddir)/src/gns/libgnunetgns.la \
-# $(top_builddir)/src/util/libgnunetutil.la \
-# $(GN_LIBINTL)
-#gnunet_dns_lookup_DEPENDENCIES = \
-# libgnunetgns.la
+test_gns_simple_delegated_lookup_SOURCES = \
+ test_gns_simple_delegated_lookup.c
+test_gns_simple_delegated_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_simple_delegated_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_mx_lookup_SOURCES = \
+ test_gns_simple_mx_lookup.c
+test_gns_simple_mx_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_simple_mx_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_zkey_lookup_SOURCES = \
+ test_gns_simple_zkey_lookup.c
+test_gns_simple_zkey_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_simple_zkey_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_dht_delegated_lookup_SOURCES = \
+ test_gns_dht_delegated_lookup.c
+test_gns_dht_delegated_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_dht_delegated_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_shorten_SOURCES = \
+ test_gns_simple_shorten.c
+test_gns_simple_shorten_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_simple_shorten_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_get_authority_SOURCES = \
+ test_gns_simple_get_authority.c
+test_gns_simple_get_authority_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_simple_get_authority_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+
+test_gns_pseu_shorten_SOURCES = \
+ test_gns_pseu_shorten.c
+test_gns_pseu_shorten_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_pseu_shorten_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+
+test_gns_max_queries_SOURCES = \
+ test_gns_max_queries.c
+test_gns_max_queries_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+test_gns_max_queries_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+gnunet_gns_SOURCES = \
+ gnunet-gns.c
+gnunet_gns_LDADD = \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(GN_LIBINTL)
+gnunet_gns_DEPENDENCIES = \
+ libgnunetgns.la
+
+gnunet_gns_proxy_SOURCES = \
+ gnunet-gns-proxy.c gns_proxy_proto.h
+gnunet_gns_proxy_LDADD = -lmicrohttpd \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(GN_LIBINTL)
+gnunet_gns_proxy_DEPENDENCIES = \
+ libgnunetgns.la
gnunet_service_gns_SOURCES = \
- gnunet-service-gns.c
+ gnunet-service-gns.c \
+ gnunet-service-gns_resolver.c gnunet-service-gns_resolver.h \
+ gnunet-service-gns_interceptor.c gnunet-service-gns_interceptor.h
gnunet_service_gns_LDADD = \
- $(top_builddir)/src/tun/libgnunettun.la \
- $(top_builddir)/src/mesh/libgnunetmesh.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/dns/libgnunetdns.la \
$(top_builddir)/src/dns/libgnunetdnsparser.la \
$(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/gns/libgnunetnamestore.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
$(GN_LIBINTL)
gnunet_service_gns_DEPENDENCIES = \
- $(top_builddir)/src/tun/libgnunettun.la \
- $(top_builddir)/src/mesh/libgnunetmesh.la \
$(top_builddir)/src/statistics/libgnunetstatistics.la \
$(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/dns/libgnunetdns.la \
$(top_builddir)/src/dns/libgnunetdnsparser.la \
$(top_builddir)/src/dht/libgnunetdht.la \
- $(top_builddir)/src/gns/libgnunetnamestore.la
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
+
+
+gnunet_gns_fcfsd_SOURCES = \
+ gnunet-gns-fcfsd.c
+gnunet_gns_fcfsd_LDADD = -lmicrohttpd \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(GN_LIBINTL)
+gnunet_gns_fcfsd_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
+
libgnunetgns_la_SOURCES = \
gns_api.c gns.h
libgnunetgns_la_LIBADD = \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
+ $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
libgnunetgns_la_LDFLAGS = \
$(GN_LIB_LDFLAGS)
libgnunetgns_la_DEPENDENCIES = \
- $(top_builddir)/src/util/libgnunetutil.la
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
libgnunet_plugin_block_gns_la_SOURCES = \
plugin_block_gns.c
libgnunet_plugin_block_gns_la_LIBADD = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/block/libgnunetblock.la
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
libgnunet_plugin_block_gns_la_LDFLAGS = \
$(GN_PLUGIN_LDFLAGS)
libgnunet_plugin_block_gns_la_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/block/libgnunetblock.la
+ $(top_builddir)/src/block/libgnunetblock.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la
#Build stub api
-libgnunetnamestore_la_SOURCES = \
- namestore_stub_api.c
-libgnunetnamestore_la_LIBADD = \
- $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
-libgnunetnamestore_la_LDFLAGS = \
- $(GN_LIB_LDFLAGS)
-libgnunetnamestore_la_DEPENDENCIES = \
- $(top_builddir)/src/util/libgnunetutil.la
+#libgnunetnamestore_la_SOURCES = \
+# namestore_stub_api.c
+#libgnunetnamestore_la_LIBADD = \
+# $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
+#libgnunetnamestore_la_LDFLAGS = \
+# $(GN_LIB_LDFLAGS)
+#libgnunetnamestore_la_DEPENDENCIES = \
+# $(top_builddir)/src/util/libgnunetutil.la
if ENABLE_TEST_RUN
-TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
+if LINUX
+TESTS = $(check_PROGRAMS)
+endif
endif
EXTRA_DIST = \
- $(check_SCRIPTS) \
- test_gns_twopeer.conf
+ test_gns_defaults.conf \
+ test_gns_simple_lookup.conf \
+ test_gns_dht_default.conf
+
diff --git a/src/gns/Makefile.in b/src/gns/Makefile.in
index 87422ab..5bdd92a 100644
--- a/src/gns/Makefile.in
+++ b/src/gns/Makefile.in
@@ -37,8 +37,17 @@ POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
target_triplet = @target@
-bin_PROGRAMS = gnunet-service-gns$(EXEEXT)
-check_PROGRAMS = test_gns_twopeer$(EXEEXT)
+bin_PROGRAMS = gnunet-service-gns$(EXEEXT) $(am__EXEEXT_1) \
+ $(am__EXEEXT_2) gnunet-gns$(EXEEXT)
+check_PROGRAMS = test_gns_simple_shorten$(EXEEXT) \
+ test_gns_simple_get_authority$(EXEEXT) \
+ test_gns_simple_lookup$(EXEEXT) \
+ test_gns_simple_delegated_lookup$(EXEEXT) \
+ test_gns_simple_mx_lookup$(EXEEXT) \
+ test_gns_simple_zkey_lookup$(EXEEXT) \
+ test_gns_dht_delegated_lookup$(EXEEXT) \
+ test_gns_pseu_shorten$(EXEEXT) test_gns_max_queries$(EXEEXT) \
+ test_gns_dht_threepeer$(EXEEXT)
subdir = src/gns
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
$(srcdir)/gns.conf.in
@@ -101,18 +110,52 @@ libgnunetgns_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
$(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
$(AM_CFLAGS) $(CFLAGS) $(libgnunetgns_la_LDFLAGS) $(LDFLAGS) \
-o $@
-am_libgnunetnamestore_la_OBJECTS = namestore_stub_api.lo
-libgnunetnamestore_la_OBJECTS = $(am_libgnunetnamestore_la_OBJECTS)
-libgnunetnamestore_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC \
- $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=link $(CCLD) \
- $(AM_CFLAGS) $(CFLAGS) $(libgnunetnamestore_la_LDFLAGS) \
- $(LDFLAGS) -o $@
+@HAVE_MHD_TRUE@am__EXEEXT_1 = gnunet-gns-fcfsd$(EXEEXT)
+@HAVE_MHD_TRUE@am__EXEEXT_2 = gnunet-gns-proxy$(EXEEXT)
PROGRAMS = $(bin_PROGRAMS)
-am_gnunet_service_gns_OBJECTS = gnunet-service-gns.$(OBJEXT)
-gnunet_service_gns_OBJECTS = $(am_gnunet_service_gns_OBJECTS)
+am_gnunet_gns_OBJECTS = gnunet-gns.$(OBJEXT)
+gnunet_gns_OBJECTS = $(am_gnunet_gns_OBJECTS)
am__DEPENDENCIES_1 =
-am_test_gns_twopeer_OBJECTS = test_gns_twopeer.$(OBJEXT)
-test_gns_twopeer_OBJECTS = $(am_test_gns_twopeer_OBJECTS)
+am_gnunet_gns_fcfsd_OBJECTS = gnunet-gns-fcfsd.$(OBJEXT)
+gnunet_gns_fcfsd_OBJECTS = $(am_gnunet_gns_fcfsd_OBJECTS)
+am_gnunet_gns_proxy_OBJECTS = gnunet-gns-proxy.$(OBJEXT)
+gnunet_gns_proxy_OBJECTS = $(am_gnunet_gns_proxy_OBJECTS)
+am_gnunet_service_gns_OBJECTS = gnunet-service-gns.$(OBJEXT) \
+ gnunet-service-gns_resolver.$(OBJEXT) \
+ gnunet-service-gns_interceptor.$(OBJEXT)
+gnunet_service_gns_OBJECTS = $(am_gnunet_service_gns_OBJECTS)
+am_test_gns_dht_delegated_lookup_OBJECTS = \
+ test_gns_dht_delegated_lookup.$(OBJEXT)
+test_gns_dht_delegated_lookup_OBJECTS = \
+ $(am_test_gns_dht_delegated_lookup_OBJECTS)
+am_test_gns_dht_threepeer_OBJECTS = test_gns_dht_threepeer.$(OBJEXT)
+test_gns_dht_threepeer_OBJECTS = $(am_test_gns_dht_threepeer_OBJECTS)
+am_test_gns_max_queries_OBJECTS = test_gns_max_queries.$(OBJEXT)
+test_gns_max_queries_OBJECTS = $(am_test_gns_max_queries_OBJECTS)
+am_test_gns_pseu_shorten_OBJECTS = test_gns_pseu_shorten.$(OBJEXT)
+test_gns_pseu_shorten_OBJECTS = $(am_test_gns_pseu_shorten_OBJECTS)
+am_test_gns_simple_delegated_lookup_OBJECTS = \
+ test_gns_simple_delegated_lookup.$(OBJEXT)
+test_gns_simple_delegated_lookup_OBJECTS = \
+ $(am_test_gns_simple_delegated_lookup_OBJECTS)
+am_test_gns_simple_get_authority_OBJECTS = \
+ test_gns_simple_get_authority.$(OBJEXT)
+test_gns_simple_get_authority_OBJECTS = \
+ $(am_test_gns_simple_get_authority_OBJECTS)
+am_test_gns_simple_lookup_OBJECTS = test_gns_simple_lookup.$(OBJEXT)
+test_gns_simple_lookup_OBJECTS = $(am_test_gns_simple_lookup_OBJECTS)
+am_test_gns_simple_mx_lookup_OBJECTS = \
+ test_gns_simple_mx_lookup.$(OBJEXT)
+test_gns_simple_mx_lookup_OBJECTS = \
+ $(am_test_gns_simple_mx_lookup_OBJECTS)
+am_test_gns_simple_shorten_OBJECTS = \
+ test_gns_simple_shorten.$(OBJEXT)
+test_gns_simple_shorten_OBJECTS = \
+ $(am_test_gns_simple_shorten_OBJECTS)
+am_test_gns_simple_zkey_lookup_OBJECTS = \
+ test_gns_simple_zkey_lookup.$(OBJEXT)
+test_gns_simple_zkey_lookup_OBJECTS = \
+ $(am_test_gns_simple_zkey_lookup_OBJECTS)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@@ -140,17 +183,77 @@ AM_V_GEN = $(am__v_GEN_$(V))
am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
am__v_GEN_0 = @echo " GEN " $@;
SOURCES = $(libgnunet_plugin_block_gns_la_SOURCES) \
- $(libgnunetgns_la_SOURCES) $(libgnunetnamestore_la_SOURCES) \
- $(gnunet_service_gns_SOURCES) $(test_gns_twopeer_SOURCES)
+ $(libgnunetgns_la_SOURCES) $(gnunet_gns_SOURCES) \
+ $(gnunet_gns_fcfsd_SOURCES) $(gnunet_gns_proxy_SOURCES) \
+ $(gnunet_service_gns_SOURCES) \
+ $(test_gns_dht_delegated_lookup_SOURCES) \
+ $(test_gns_dht_threepeer_SOURCES) \
+ $(test_gns_max_queries_SOURCES) \
+ $(test_gns_pseu_shorten_SOURCES) \
+ $(test_gns_simple_delegated_lookup_SOURCES) \
+ $(test_gns_simple_get_authority_SOURCES) \
+ $(test_gns_simple_lookup_SOURCES) \
+ $(test_gns_simple_mx_lookup_SOURCES) \
+ $(test_gns_simple_shorten_SOURCES) \
+ $(test_gns_simple_zkey_lookup_SOURCES)
DIST_SOURCES = $(libgnunet_plugin_block_gns_la_SOURCES) \
- $(libgnunetgns_la_SOURCES) $(libgnunetnamestore_la_SOURCES) \
- $(gnunet_service_gns_SOURCES) $(test_gns_twopeer_SOURCES)
+ $(libgnunetgns_la_SOURCES) $(gnunet_gns_SOURCES) \
+ $(gnunet_gns_fcfsd_SOURCES) $(gnunet_gns_proxy_SOURCES) \
+ $(gnunet_service_gns_SOURCES) \
+ $(test_gns_dht_delegated_lookup_SOURCES) \
+ $(test_gns_dht_threepeer_SOURCES) \
+ $(test_gns_max_queries_SOURCES) \
+ $(test_gns_pseu_shorten_SOURCES) \
+ $(test_gns_simple_delegated_lookup_SOURCES) \
+ $(test_gns_simple_get_authority_SOURCES) \
+ $(test_gns_simple_lookup_SOURCES) \
+ $(test_gns_simple_mx_lookup_SOURCES) \
+ $(test_gns_simple_shorten_SOURCES) \
+ $(test_gns_simple_zkey_lookup_SOURCES)
+RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
+ html-recursive info-recursive install-data-recursive \
+ install-dvi-recursive install-exec-recursive \
+ install-html-recursive install-info-recursive \
+ install-pdf-recursive install-ps-recursive install-recursive \
+ installcheck-recursive installdirs-recursive pdf-recursive \
+ ps-recursive uninstall-recursive
DATA = $(pkgcfg_DATA)
+RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
+ distclean-recursive maintainer-clean-recursive
+AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGETS:-recursive=) \
+ $(RECURSIVE_CLEAN_TARGETS:-recursive=) tags TAGS ctags CTAGS \
+ distdir
ETAGS = etags
CTAGS = ctags
am__tty_colors = \
red=; grn=; lgn=; blu=; std=
+DIST_SUBDIRS = . nss
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+am__relativize = \
+ dir0=`pwd`; \
+ sed_first='s,^\([^/]*\)/.*$$,\1,'; \
+ sed_rest='s,^[^/]*/*,,'; \
+ sed_last='s,^.*/\([^/]*\)$$,\1,'; \
+ sed_butlast='s,/*[^/]*$$,,'; \
+ while test -n "$$dir1"; do \
+ first=`echo "$$dir1" | sed -e "$$sed_first"`; \
+ if test "$$first" != "."; then \
+ if test "$$first" = ".."; then \
+ dir2=`echo "$$dir0" | sed -e "$$sed_last"`/"$$dir2"; \
+ dir0=`echo "$$dir0" | sed -e "$$sed_butlast"`; \
+ else \
+ first2=`echo "$$dir2" | sed -e "$$sed_first"`; \
+ if test "$$first2" = "$$first"; then \
+ dir2=`echo "$$dir2" | sed -e "$$sed_rest"`; \
+ else \
+ dir2="../$$dir2"; \
+ fi; \
+ dir0="$$dir0"/"$$first"; \
+ fi; \
+ fi; \
+ dir1=`echo "$$dir1" | sed -e "$$sed_rest"`; \
+ done; \
+ reldir="$$dir2"
ACLOCAL = @ACLOCAL@
AMTAR = @AMTAR@
AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
@@ -206,6 +309,7 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
INTLLIBS = @INTLLIBS@
INTL_MACOSX_LIBS = @INTL_MACOSX_LIBS@
+JAVAPORT = @JAVAPORT@
LD = @LD@
LDFLAGS = @LDFLAGS@
LIBADD_DL = @LIBADD_DL@
@@ -239,6 +343,7 @@ LT_DLLOADERS = @LT_DLLOADERS@
LT_DLPREOPEN = @LT_DLPREOPEN@
MAKEINFO = @MAKEINFO@
MKDIR_P = @MKDIR_P@
+MONKEYPREFIX = @MONKEYPREFIX@
MSGFMT = @MSGFMT@
MSGFMT_015 = @MSGFMT_015@
MSGMERGE = @MSGMERGE@
@@ -356,6 +461,8 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
INCLUDES = -I$(top_srcdir)/src/include
+@HAVE_GLIBCNSS_TRUE@NSS_SUBDIR = nss
+SUBDIRS = . $(NSS_SUBDIR)
@MINGW_TRUE@WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
@USE_COVERAGE_TRUE@AM_CFLAGS = --coverage -O0
pkgcfgdir = $(pkgdatadir)/config.d/
@@ -364,107 +471,275 @@ pkgcfg_DATA = \
gns.conf
lib_LTLIBRARIES = \
- libgnunetgns.la libgnunetnamestore.la
-
+ libgnunetgns.la
-#noinst_PROGRAMS = \
-# gnunet-gns-lookup
-check_SCRIPTS = \
- test_gnunet_gns.sh
+@HAVE_MHD_TRUE@DO_FCFSD = gnunet-gns-fcfsd
+@HAVE_MHD_TRUE@DO_PROXY = gnunet-gns-proxy
+# test_gns_simple_lookup
+# test_gns_simple_delegated_lookup
+# test_gns_dht_delegated_lookup
plugin_LTLIBRARIES = \
libgnunet_plugin_block_gns.la
-test_gns_twopeer_SOURCES = \
- test_gns_twopeer.c
+test_gns_dht_threepeer_SOURCES = \
+ test_gns_dht_threepeer.c
+
+test_gns_dht_threepeer_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_dht_threepeer_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_lookup_SOURCES = \
+ test_gns_simple_lookup.c
+
+test_gns_simple_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_delegated_lookup_SOURCES = \
+ test_gns_simple_delegated_lookup.c
+
+test_gns_simple_delegated_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_delegated_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_mx_lookup_SOURCES = \
+ test_gns_simple_mx_lookup.c
+
+test_gns_simple_mx_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_mx_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_zkey_lookup_SOURCES = \
+ test_gns_simple_zkey_lookup.c
+
+test_gns_simple_zkey_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_zkey_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_dht_delegated_lookup_SOURCES = \
+ test_gns_dht_delegated_lookup.c
+
+test_gns_dht_delegated_lookup_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_dht_delegated_lookup_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_shorten_SOURCES = \
+ test_gns_simple_shorten.c
+
+test_gns_simple_shorten_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_shorten_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_simple_get_authority_SOURCES = \
+ test_gns_simple_get_authority.c
-test_gns_twopeer_LDADD = \
+test_gns_simple_get_authority_LDADD = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
-test_gns_twopeer_DEPENDENCIES = \
+test_gns_simple_get_authority_DEPENDENCIES = \
$(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
$(top_builddir)/src/testing/libgnunettesting.la
+test_gns_pseu_shorten_SOURCES = \
+ test_gns_pseu_shorten.c
+
+test_gns_pseu_shorten_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_pseu_shorten_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/dht/libgnunetdht.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_max_queries_SOURCES = \
+ test_gns_max_queries.c
+
+test_gns_max_queries_LDADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+test_gns_max_queries_DEPENDENCIES = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/testing/libgnunettesting.la
+
+gnunet_gns_SOURCES = \
+ gnunet-gns.c
+
+gnunet_gns_LDADD = \
+ $(top_builddir)/src/gns/libgnunetgns.la \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/namestore/libgnunetnamestore.la \
+ $(GN_LIBINTL)