aboutsummaryrefslogtreecommitdiff
path: root/src/gns/nss/Makefile.am
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
committerBertrand Marc <beberking@gmail.com>2012-06-06 20:47:48 +0200
commit740b30688bd745a527f96f9116c19acb3480971a (patch)
tree2709a3f4dba11c174aa9e1ba3612e30c578e76a9 /src/gns/nss/Makefile.am
parent2b81464a43485fcc8ce079fafdee7b7a171835f4 (diff)
Imported Upstream version 0.9.3upstream/0.9.3
Diffstat (limited to 'src/gns/nss/Makefile.am')
-rw-r--r--src/gns/nss/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/src/gns/nss/Makefile.am b/src/gns/nss/Makefile.am
new file mode 100644
index 0000000..5e8ab5a
--- /dev/null
+++ b/src/gns/nss/Makefile.am
@@ -0,0 +1,59 @@
+# $Id$
+#
+# This file taken and modified from nss-gns.
+#
+# nss-gns is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# nss-gns is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with nss-gns; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = map-file
+
+AM_LDFLAGS=-avoid-version -module -export-dynamic
+
+if HAVE_SUDO
+nssdir = /lib/
+else
+nssdir = $(libdir)
+endif
+
+LIBTOOL = $(SUDO_BINARY) $(SHELL) $(top_builddir)/libtool
+
+if !MINGW
+nss_LTLIBRARIES = \
+ libnss_gns.la \
+ libnss_gns4.la \
+ libnss_gns6.la
+endif
+
+sources = nss_gns_query.h nss_gns_query.c
+
+# GNU Libc
+libnss_gns_la_SOURCES= $(sources) nss_gns.c
+libnss_gns_la_CFLAGS=$(AM_CFLAGS) -D_GNU_SOURCE
+libnss_gns_la_LDFLAGS=$(AM_LDFLAGS) -shrext .so.2 -Wl,-version-script=$(srcdir)/map-file
+
+libnss_gns4_la_SOURCES=$(libnss_gns_la_SOURCES)
+libnss_gns4_la_CFLAGS=$(libnss_gns_la_CFLAGS) -DNSS_IPV4_ONLY=1
+libnss_gns4_la_LDFLAGS=$(libnss_gns_la_LDFLAGS)
+
+libnss_gns6_la_SOURCES=$(libnss_gns_la_SOURCES)
+libnss_gns6_la_CFLAGS=$(libnss_gns_la_CFLAGS) -DNSS_IPV6_ONLY=1
+libnss_gns6_la_LDFLAGS=$(libnss_gns_la_LDFLAGS)
+
+install-data-hook:
+ $(SUDO_BINARY) $(SHELL) $(top_builddir)/libtool --finish $(nssdir)
+ $(SUDO_BINARY) rm -f $(nssdir)/libnss_gns.la $(nssdir)/libnss_gns4.la $(nssdir)/libnss_gns6.la
+
+uninstall-hook:
+ $(SUDO_BINARY) rm -f $(nssdir)/libnss_gns.so.2 $(nssdir)/libnss_gns4.so.2 $(nssdir)/libnss_gns6.so.2