aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-05-02 21:43:37 +0200
committerBertrand Marc <beberking@gmail.com>2012-05-02 21:43:37 +0200
commit2b81464a43485fcc8ce079fafdee7b7a171835f4 (patch)
tree394774c0f735199b57d51a2d3840356317853fe1 /src/Makefile.am
Imported Upstream version 0.9.2upstream/0.9.2
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c3474d5
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,43 @@
+#if WANT_FRAMEWORK
+# INTLEMU_SUBDIRS = intlemu
+#endif
+
+if HAVE_EXPERIMENTAL
+ EXP_DIR = chat dv gns stream
+endif
+
+if LINUX
+# All of these currently only work on GNU/Linux
+ LINUX_DIR = dns exit vpn pt
+endif
+
+
+SUBDIRS = \
+ include $(INTLEMU_SUBDIRS) \
+ util \
+ hello \
+ tun \
+ block \
+ statistics \
+ arm \
+ peerinfo \
+ datacache \
+ datastore \
+ namestore \
+ template \
+ ats \
+ nat \
+ fragmentation \
+ transport \
+ peerinfo-tool \
+ core \
+ testing \
+ nse \
+ dht \
+ hostlist \
+ topology \
+ fs \
+ mesh \
+ $(LINUX_DIR) \
+ integration-tests \
+ $(EXP_DIR)