aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Marc <beberking@gmail.com>2012-08-05 20:12:01 +0200
committerBertrand Marc <beberking@gmail.com>2012-08-05 20:12:01 +0200
commit0132fc81e788ac92741a56604e185b40ca9de9a2 (patch)
tree10835c4d439c7b8a4ace8f7aa020ced7e2420bdd
parent1086271ff9c59adec8da95f948d637bc1f4a63e4 (diff)
Revert "Rewrite gnunet-server.init based on /etc/init.d/skeleton and make gnunet-server depend on lsb-base to use LSB logging." to get a freeze-exception for wheezy.
This reverts commit cdca861916def04e11e716552a6be8ed5e048a80.
-rw-r--r--debian/control2
-rw-r--r--debian/gnunet-server.init141
2 files changed, 49 insertions, 94 deletions
diff --git a/debian/control b/debian/control
index cfe0f52..e14b710 100644
--- a/debian/control
+++ b/debian/control
@@ -75,7 +75,7 @@ Architecture: any
Pre-Depends: ${misc:Pre-Depends}
Depends:
${misc:Depends}, ${shlibs:Depends}, gnunet-common (= ${binary:Version}),
- adduser, gettext, netbase, lsb-base
+ adduser, gettext, netbase
Suggests: miniupnpc
Breaks: gnunet-fuse (<<0.9), gnunet-client (<<0.9)
Replaces: gnunet-fuse (<<0.9), gnunet-client (<<0.9)
diff --git a/debian/gnunet-server.init b/debian/gnunet-server.init
index 775f923..1a77f1e 100644
--- a/debian/gnunet-server.init
+++ b/debian/gnunet-server.init
@@ -1,109 +1,64 @@
-#! /bin/sh
+#!/bin/sh
+
### BEGIN INIT INFO
-# Provides: gnunet-server
-# Required-Start: $remote_fs $syslog $network
-# Required-Stop: $remote_fs $syslog $network
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Starts the GNUnet server at boot time.
-# Description: GNUnet is a secure, trust-based peer-to-peer framework.
+# Provides: gnunet-server
+# Required-Start: $syslog $network $local_fs $remote_fs
+# Required-Stop: $syslog $network $local_fs $remote_fs
+# Should-Start:
+# Should-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: Starts the GNUnet server at boot time.
+# Description: GNUnet is a secure, trust-based peer-to-peer framework.
### END INIT INFO
-PATH=/sbin:/usr/sbin:/bin:/usr/bin
-DESC="GNUnet"
-NAME=gnunet-server
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/bin/gnunet-service-arm
+NAME=gnunet-service-arm
+DESC=GNUnet
LOGFILE=/var/log/gnunetd/gnunetd.log
-DAEMON_ARGS="-c /etc/gnunet.conf -d -l $LOGFILE"
-SCRIPTNAME=/etc/init.d/$NAME
-# Exit if the package is not installed
-[ -x "$DAEMON" ] || exit 0
+test -x "${DAEMON}" || exit 0
-# Read configuration variable file if it is present
-[ -r /etc/default/$NAME ] && . /etc/default/$NAME
+set -e
-[ "${GNUNET_AUTOSTART}" != "true" ] && exit 0
+# Get configuration
+if [ -f /etc/default/gnunet-server ]
+then
+ . /etc/default/gnunet-server
+fi
-# Define LSB log_* functions.
-. /lib/lsb/init-functions
+if [ "${GNUNET_AUTOSTART}" != "true" ]
+then
+ exit 0
+fi
-#
-# Function that starts the daemon/service
-#
-do_start()
-{
- # Return
- # 0 if daemon has been started
- # 1 if daemon was already running
- # 2 if daemon could not be started
- start-stop-daemon --start --quiet --exec $DAEMON --test > /dev/null \
- || return 1
- start-stop-daemon --start --quiet --chuid $GNUNET_USER --exec $DAEMON -- \
- $DAEMON_ARGS \
- || return 2
-}
+case "${1}" in
+ start)
+ echo -n "Starting ${DESC}: "
+ start-stop-daemon --start --chuid ${GNUNET_USER} \
+ --oknodo --quiet --exec ${DAEMON} -- -c \
+ /etc/gnunet.conf -d -l $LOGFILE
+ echo "${NAME}."
+ ;;
-#
-# Function that stops the daemon/service
-#
-do_stop()
-{
- # Return
- # 0 if daemon has been stopped
- # 1 if daemon was already stopped
- # 2 if daemon could not be stopped
- # other if a failure occurred
- start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 --exec $DAEMON
- RETVAL="$?"
- [ "$RETVAL" = 2 ] && return 2
- start-stop-daemon --stop --quiet --oknodo --retry=0/30/KILL/5 --exec $DAEMON
- [ "$?" = 2 ] && return 2
- return "$RETVAL"
-}
+ stop)
+ echo -n "Stopping ${DESC}: "
+ start-stop-daemon --stop --retry 15 \
+ --oknodo --quiet --exec ${DAEMON}
+ echo "${NAME}."
+ ;;
-case "$1" in
- start)
- log_daemon_msg "Starting $DESC" "$NAME"
- do_start
- case "$?" in
- 0|1) log_end_msg 0 ;;
- 2) log_end_msg 1 ;;
- esac
- ;;
- stop)
- log_daemon_msg "Stopping $DESC" "$NAME"
- do_stop
- case "$?" in
- 0|1) log_end_msg 0 ;;
- 2) log_end_msg 1 ;;
- esac
- ;;
- status)
- status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
- ;;
- restart|force-reload)
- log_daemon_msg "Restarting $DESC" "$NAME"
- do_stop
- case "$?" in
- 0|1)
- do_start
- case "$?" in
- 0) log_end_msg 0 ;;
- 1) log_end_msg 1 ;; # Old process is still running
- *) log_end_msg 1 ;; # Failed to start
- esac
+ restart|force-reload)
+ ${0} stop
+ sleep 1
+ ${0} start
;;
- *)
- # Failed to stop
- log_end_msg 1
+
+ *)
+ echo "Usage: ${0} {start|stop|restart|force-reload}" >&2
+ exit 1
;;
- esac
- ;;
- *)
- echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
- exit 3
- ;;
esac
-:
+exit 0