summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/matchbox-keyboard
diff options
context:
space:
mode:
Diffstat (limited to 'org.handhelds.familiar/packages/matchbox-keyboard')
-rw-r--r--org.handhelds.familiar/packages/matchbox-keyboard/files/fontsize.patch11
-rw-r--r--org.handhelds.familiar/packages/matchbox-keyboard/matchbox-keyboard_0.1.bb15
2 files changed, 26 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/matchbox-keyboard/files/fontsize.patch b/org.handhelds.familiar/packages/matchbox-keyboard/files/fontsize.patch
new file mode 100644
index 0000000..f57aff2
--- /dev/null
+++ b/org.handhelds.familiar/packages/matchbox-keyboard/files/fontsize.patch
@@ -0,0 +1,11 @@
+--- matchbox-keyboard-0.1/src/matchbox-keyboard.c.orig 2006-11-04 00:41:52.000000000 +0100
++++ matchbox-keyboard-0.1/src/matchbox-keyboard.c 2006-11-04 00:29:25.000000000 +0100
+@@ -77,7 +77,7 @@
+ kb->key_pad = 0;
+ kb->col_spacing = 0;
+ kb->row_spacing = 0;
+- kb->font_pt_size = 8;
++ kb->font_pt_size = 6;
+ }
+
+ if (!mb_kbd_config_load(kb, variant))
diff --git a/org.handhelds.familiar/packages/matchbox-keyboard/matchbox-keyboard_0.1.bb b/org.handhelds.familiar/packages/matchbox-keyboard/matchbox-keyboard_0.1.bb
new file mode 100644
index 0000000..2cf98e4
--- /dev/null
+++ b/org.handhelds.familiar/packages/matchbox-keyboard/matchbox-keyboard_0.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Matchbox keyboard"
+LICENSE = "GPL"
+DEPENDS = "libfakekey expat libxft"
+SECTION = "x11/wm"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/${@'.'.join(bb.data.getVar('PV', d, 1).split('.')[:2])}/${PN}-${PV}.tar.bz2 \
+ file://fontsize.patch;patch=1"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${bindir} \
+ ${datadir}/applications \
+ ${datadir}/pixmaps \
+ ${datadir}/matchbox-keyboard"
+