summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb')
-rw-r--r--org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb b/org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb
new file mode 100644
index 0000000..6883d12
--- /dev/null
+++ b/org.handhelds.familiar/packages/libfakekey/libfakekey_0.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "library for converting characters to X key-presses"
+LICENSE = "GPL"
+DEPENDS = "xtst"
+SECTION = "x11/wm"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/${@'.'.join(bb.data.getVar('PV', d, 1).split('.')[:2])}/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir} \
+ ${datadir}/applications \
+ ${datadir}/pixmaps"
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/fakekey
+ install -m 0644 ${S}/fakekey/fakekey.h ${STAGING_INCDIR}/fakekey
+ oe_libinstall -so -C src libfakekey ${STAGING_LIBDIR}
+}
+