summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/xstroke
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/xstroke
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/xstroke')
-rw-r--r--org.handhelds.familiar/packages/xstroke/xstroke-0.6/auto-disable.patch20
-rw-r--r--org.handhelds.familiar/packages/xstroke/xstroke_0.6.bb12
2 files changed, 32 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/xstroke/xstroke-0.6/auto-disable.patch b/org.handhelds.familiar/packages/xstroke/xstroke-0.6/auto-disable.patch
new file mode 100644
index 0000000..693460c
--- /dev/null
+++ b/org.handhelds.familiar/packages/xstroke/xstroke-0.6/auto-disable.patch
@@ -0,0 +1,20 @@
+Index: control_win.c
+===================================================================
+RCS file: /cvs/xstroke/xstroke/control_win.c,v
+retrieving revision 1.21
+diff -u -r1.21 control_win.c
+--- control_win.c 28 Sep 2003 11:53:42 -0000 1.21
++++ control_win.c 24 Jul 2004 15:02:52 -0000
+@@ -646,9 +646,11 @@
+ if (XGetWindowAttributes(dpy, window, &attr)) {
+ if (attr.all_event_masks & (KeyPressMask | KeyReleaseMask)) {
+ return 1;
++ } else if (attr.all_event_masks & PointerMotionMask) {
++ return 0;
+ }
+ }
+- return 0;
++ return 1;
+ }
+
+ /*
diff --git a/org.handhelds.familiar/packages/xstroke/xstroke_0.6.bb b/org.handhelds.familiar/packages/xstroke/xstroke_0.6.bb
new file mode 100644
index 0000000..31542e8
--- /dev/null
+++ b/org.handhelds.familiar/packages/xstroke/xstroke_0.6.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Gesture recognition input method for X11"
+LICENSE = "GPL"
+SECTION = "x11"
+PRIORITY = "optional"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "x11 xft xtst xpm"
+PR = "r2"
+
+SRC_URI = "http://www.oesources.org/source/xstroke-0.6.tar.gz \
+ file://auto-disable.patch;patch=1;pnum=0"
+
+inherit autotools pkgconfig