summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/totem
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/totem
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/totem')
-rw-r--r--org.handhelds.familiar/packages/totem/files/cflags.patch33
-rw-r--r--org.handhelds.familiar/packages/totem/files/gtkonly.patch38
-rw-r--r--org.handhelds.familiar/packages/totem/files/include.patch11
-rw-r--r--org.handhelds.familiar/packages/totem/files/intl.patch33
-rw-r--r--org.handhelds.familiar/packages/totem/files/nonautilus.patch16
-rw-r--r--org.handhelds.familiar/packages/totem/files/omf.patch13
-rw-r--r--org.handhelds.familiar/packages/totem/totem_0.99.15.bb30
-rw-r--r--org.handhelds.familiar/packages/totem/totem_1.0.4.bb33
8 files changed, 207 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/totem/files/cflags.patch b/org.handhelds.familiar/packages/totem/files/cflags.patch
new file mode 100644
index 0000000..a032473
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/files/cflags.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/src/Makefile.am~cflags
++++ totem-1.0.4/src/Makefile.am
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = bvw-test list_v4l test-parser disc-test metadata-test
++#noinst_PROGRAMS = bvw-test list_v4l test-parser disc-test metadata-test
+
+ if TOTEM_VANITY
+ VANITY=vanity
+@@ -179,8 +179,10 @@
+ list_v4l_SOURCES = list_v4l.c $(BACON_V4L_SELECTION)
+ list_v4l_LDADD = $(GTK_LIBS)
+
++test_parser_CFLAGS = $(TOTEM_PLPARSER_CFLAGS)
+ test_parser_SOURCES = test-parser.c
+ test_parser_LDADD = \
++ $(TOTEM_PLPARSER_LIBS)
+ $(EXTRA_GNOME_LIBS) \
+ libtotem-plparser.la
+
+@@ -224,6 +226,8 @@
+ totem-disc.h \
+ totem-pl-parser.h
+
++libtotem_plparser_la_CFLAGS = $(TOTEM_PLPARSER_CFLAGS)
++
+ libtotem_plparser_la_LDFLAGS = \
+ -version-info $(PLPARSER_LT_VERSION) \
+ -no-undefined \
diff --git a/org.handhelds.familiar/packages/totem/files/gtkonly.patch b/org.handhelds.familiar/packages/totem/files/gtkonly.patch
new file mode 100644
index 0000000..8a7fbd2
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/files/gtkonly.patch
@@ -0,0 +1,38 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/src/totem.c~gtkonly
++++ totem-1.0.4/src/totem.c
+@@ -1667,8 +1667,10 @@
+ totem_action_set_mrl_and_play (totem, mrl);
+ g_free (mrl);
+
++#ifndef HAVE_GTK_ONLY
+ gnome_entry_append_history (GNOME_ENTRY (gentry),
+ TRUE, uri);
++#endif
+ }
+ }
+
+@@ -3593,7 +3595,9 @@
+ /* Properties */
+ totem->properties = bacon_video_widget_properties_new ();
+
++#ifndef HAVE_GTK_ONLY
+ totem_session_setup (totem, argv);
++#endif
+ totem_setup_recent (totem);
+ totem_callback_connect (totem);
+ totem_setup_window (totem);
+@@ -3617,7 +3621,9 @@
+ /* Command-line handling */
+ if (totem_options_process_late (totem, &argc, &argv) != FALSE)
+ {
++#ifndef HAVE_GTK_ONLY
+ totem_session_restore (totem, argv);
++#endif
+ } else if (argc >= 1 && totem_action_open_files (totem, argv)) {
+ totem_action_play_pause (totem);
+ } else {
diff --git a/org.handhelds.familiar/packages/totem/files/include.patch b/org.handhelds.familiar/packages/totem/files/include.patch
new file mode 100644
index 0000000..6e99c4e
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/files/include.patch
@@ -0,0 +1,11 @@
+--- totem-0.99.15/src/video-utils.c 2004-07-03 16:54:31.000000000 -0700
++++ totem-0.99.15.new/src/video-utils.c 2004-08-04 11:03:30.822669856 -0700
+@@ -4,7 +4,7 @@
+ #include "video-utils.h"
+
+ #include <glib/gi18n.h>
+-#include <libintl.h>
++/* #include <libintl.h> */
+
+ #include <gdk/gdk.h>
+ #include <gdk/gdkx.h>
diff --git a/org.handhelds.familiar/packages/totem/files/intl.patch b/org.handhelds.familiar/packages/totem/files/intl.patch
new file mode 100644
index 0000000..2a1a32c
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/files/intl.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/src/totem.c~intl
++++ totem-1.0.4/src/totem.c
+@@ -35,6 +35,25 @@
+ #include <gtk/gtk.h>
+ #include <gdk/gdkkeysyms.h>
+ #include <stdlib.h>
++#ifdef ENABLE_NLS
++# include <libintl.h>
++# define _(String) dgettext (GETTEXT_PACKAGE, String)
++# ifdef gettext_noop
++# define N_(String) gettext_noop (String)
++# else
++# define N_(String) (String)
++# endif
++#else
++/* Stubs that do something close enough. */
++# define textdomain(String) (String)
++# define gettext(String) (String)
++# define dgettext(Domain,Message) (Message)
++# define dcgettext(Domain,Message,Type) (Message)
++# define ngettext(Singular, Plural, IsPlural) (Singular)
++# define bindtextdomain(Domain,Directory) (Domain)
++# define _(String) (String)
++# define N_(String) (String)
++#endif
+ #endif /* !HAVE_GTK_ONLY */
+
+ #include <string.h>
diff --git a/org.handhelds.familiar/packages/totem/files/nonautilus.patch b/org.handhelds.familiar/packages/totem/files/nonautilus.patch
new file mode 100644
index 0000000..3cfce7c
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/files/nonautilus.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- totem-1.0.4/configure.in~nonautilus
++++ totem-1.0.4/configure.in
+@@ -144,7 +144,7 @@
+ PKG_CHECK_MODULES(EXTRA_GNOME, glib-2.0 >= 2.6.3 gtk+-2.0 >= 2.5.6 libgnomeui-2.0 >= 2.3.3 libglade-2.0 gnome-vfs-2.0 >= 2.1.6 gnome-vfs-module-2.0 >= 2.1.6 gnome-desktop-2.0 >= 2.1.5 $MM)
+ HAVE_GNOME=yes
+ else
+- PKG_CHECK_MODULES(EXTRA_GNOME, glib-2.0 >= 2.6.3 gtk+-2.0 >= 2.5.6 libglade-2.0 gnome-vfs-2.0 >= 2.1.6 gnome-vfs-module-2.0 >= 2.1.6 libnautilus-burn >= 2.9.0 $MM)
++ PKG_CHECK_MODULES(EXTRA_GNOME, glib-2.0 >= 2.6.3 gtk+-2.0 >= 2.5.6 libglade-2.0 gnome-vfs-2.0 >= 2.1.6 gnome-vfs-module-2.0 >= 2.1.6 $MM)
+ AC_DEFINE(USE_STABLE_LIBGNOMEUI, 1, [defined if we don't have GNOME])
+ AC_DEFINE(HAVE_GTK_ONLY, 1, [defined if GNOME isn't used])
+ HAVE_GNOME=no
diff --git a/org.handhelds.familiar/packages/totem/files/omf.patch b/org.handhelds.familiar/packages/totem/files/omf.patch
new file mode 100644
index 0000000..a889db1
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/files/omf.patch
@@ -0,0 +1,13 @@
+--- totem-0.99.12/omf.make 2003-11-08 18:04:41.000000000 -0700
++++ totem-0.99.12.new/omf.make 2004-06-30 09:39:58.765495480 -0700
+@@ -41,7 +41,9 @@
+ install-data-hook-omf:
+ $(mkinstalldirs) $(DESTDIR)$(omf_dest_dir)
+ for file in $(omffile); do \
+- $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ if [ -f $$file.out ]; then \
++ $(INSTALL_DATA) $$file.out $(DESTDIR)$(omf_dest_dir)/$$file; \
++ fi; \
+ done
+ -scrollkeeper-update -o $(DESTDIR)$(omf_dest_dir)
+
diff --git a/org.handhelds.familiar/packages/totem/totem_0.99.15.bb b/org.handhelds.familiar/packages/totem/totem_0.99.15.bb
new file mode 100644
index 0000000..028a0d6
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/totem_0.99.15.bb
@@ -0,0 +1,30 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.hadess.net/totem.php3"
+LICENSE="GPL"
+
+SRC_URI="http://ftp.acc.umu.se/pub/GNOME/sources/totem/0.99/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libgnomeui"
+RDEPENDS += " libgnomeui"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}
diff --git a/org.handhelds.familiar/packages/totem/totem_1.0.4.bb b/org.handhelds.familiar/packages/totem/totem_1.0.4.bb
new file mode 100644
index 0000000..617b4aa
--- /dev/null
+++ b/org.handhelds.familiar/packages/totem/totem_1.0.4.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/multimedia"
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="A GTK2 based media player"
+HOMEPAGE="http://www.gnome.org/projects/totem/"
+LICENSE="GPL"
+
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/totem/1.0/totem-${PV}.tar.gz \
+ file://include.patch;patch=1 \
+ file://omf.patch;patch=1 \
+ file://nonautilus.patch;patch=1 \
+ file://intl.patch;patch=1 \
+ file://cflags.patch;patch=1 \
+ file://gtkonly.patch;patch=1"
+
+DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libxml2"
+
+inherit autotools
+
+EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
+
+#SELECTED_OPTIMIZATION="-O0 -g"
+LDFLAGS_append = " -Wl,--export-dynamic"
+
+pkg_postinst_totem() {
+#!/bin/sh
+if [ -n "$D" ]; then exit 1; fi;
+SOURCE=`gconftool-2 --get-default-source`
+GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
+/etc/gconf/schemas/totem.schemas > /dev/null
+}