summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/scummvm
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/scummvm
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/scummvm')
-rw-r--r--org.handhelds.familiar/packages/scummvm/files/mouse.patch36
-rw-r--r--org.handhelds.familiar/packages/scummvm/files/tremor.patch32
-rw-r--r--org.handhelds.familiar/packages/scummvm/opie-scummvm_1.0.1.bb18
-rw-r--r--org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/mouse.patch36
-rw-r--r--org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/sword1.patch16
-rw-r--r--org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/tremor.patch32
-rw-r--r--org.handhelds.familiar/packages/scummvm/scummvm-qpe_0.6.1b.bb10
-rw-r--r--org.handhelds.familiar/packages/scummvm/scummvm.inc29
-rw-r--r--org.handhelds.familiar/packages/scummvm/scummvm_0.6.0.bb36
-rw-r--r--org.handhelds.familiar/packages/scummvm/scummvm_0.6.1b.bb10
10 files changed, 255 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/scummvm/files/mouse.patch b/org.handhelds.familiar/packages/scummvm/files/mouse.patch
new file mode 100644
index 0000000..1697ac8
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/files/mouse.patch
@@ -0,0 +1,36 @@
+--- ./backends/sdl/sdl-common.cpp~mouse.patch 2004-03-05 07:23:04.000000000 +1030
++++ ./backends/sdl/sdl-common.cpp 2004-05-16 07:53:24.000000000 +0930
+@@ -866,6 +866,9 @@
+ return true;
+
+ case SDL_MOUSEBUTTONDOWN:
++#ifdef QTOPIA
++ event->event_code = EVENT_LBUTTONDOWN;
++#else
+ if (ev.button.button == SDL_BUTTON_LEFT)
+ event->event_code = EVENT_LBUTTONDOWN;
+ else if (ev.button.button == SDL_BUTTON_RIGHT)
+@@ -878,18 +881,23 @@
+ #endif
+ else
+ break;
++#endif
+
+ fillMouseEvent(*event, ev.button.x, ev.button.y);
+
+ return true;
+
+ case SDL_MOUSEBUTTONUP:
++#ifdef QTOPIA
++ event->event_code = EVENT_LBUTTONUP;
++#else
+ if (ev.button.button == SDL_BUTTON_LEFT)
+ event->event_code = EVENT_LBUTTONUP;
+ else if (ev.button.button == SDL_BUTTON_RIGHT)
+ event->event_code = EVENT_RBUTTONUP;
+ else
+ break;
++#endif
+ fillMouseEvent(*event, ev.button.x, ev.button.y);
+
+ return true;
diff --git a/org.handhelds.familiar/packages/scummvm/files/tremor.patch b/org.handhelds.familiar/packages/scummvm/files/tremor.patch
new file mode 100644
index 0000000..3acf302
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/files/tremor.patch
@@ -0,0 +1,32 @@
+--- ./sound/vorbis.cpp.old 2004-05-16 04:23:59.000000000 +0930
++++ ./sound/vorbis.cpp 2004-05-16 04:24:23.000000000 +0930
+@@ -29,7 +29,7 @@
+ #include "sound/audiostream.h"
+ #include "sound/audiocd.h"
+
+-#include <vorbis/vorbisfile.h>
++#include <tremor/ivorbisfile.h>
+
+
+ AudioStream *makeVorbisStream(OggVorbis_File *file, int duration);
+--- ./configure.old 2004-05-16 04:46:47.000000000 +0930
++++ ./configure 2004-05-16 04:50:42.000000000 +0930
+@@ -560,15 +560,15 @@
+ if test "$_vorbis" = auto ; then
+ _vorbis=no
+ cat > $TMPC << EOF
+-#include <vorbis/codec.h>
++#include <tremor/ivorbiscodec.h>
+ int main(void) { vorbis_packet_blocksize(0,0); return 0; }
+ EOF
+ cc_check $LDFLAGS $CXXFLAGS $OGG_CFLAGS $OGG_LIBS $VORBIS_CFLAGS $VORBIS_LIBS \
+- -lvorbis -logg -lm && _vorbis=yes
++ -lvorbisidec -logg -lm && _vorbis=yes
+ fi
+ if test "$_vorbis" = yes ; then
+ _def_vorbis='#define USE_VORBIS'
+- LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisfile -lvorbis -logg"
++ LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisidec -logg"
+ INCLUDES="$INCLUDES $OGG_CFLAGS $VORBIS_CFLAGS"
+ else
+ _def_vorbis='#undef USE_VORBIS'
diff --git a/org.handhelds.familiar/packages/scummvm/opie-scummvm_1.0.1.bb b/org.handhelds.familiar/packages/scummvm/opie-scummvm_1.0.1.bb
new file mode 100644
index 0000000..45116eb
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/opie-scummvm_1.0.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "opie-scummvm"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "opie-scummvm"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+RDEPENDS = "scummvm-qpe"
+SRC_URI = "http://sickpeople.wmc-allstars.com/law/files/scummvm/opie-scummvm-${PV}-r0_arm.tar.bz2"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}
+ install -m 0755 ${WORKDIR}/${APPNAME}-1.0.1/scummvm.png ${D}${palmtopdir}/pics/
+}
+
diff --git a/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/mouse.patch b/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/mouse.patch
new file mode 100644
index 0000000..1697ac8
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/mouse.patch
@@ -0,0 +1,36 @@
+--- ./backends/sdl/sdl-common.cpp~mouse.patch 2004-03-05 07:23:04.000000000 +1030
++++ ./backends/sdl/sdl-common.cpp 2004-05-16 07:53:24.000000000 +0930
+@@ -866,6 +866,9 @@
+ return true;
+
+ case SDL_MOUSEBUTTONDOWN:
++#ifdef QTOPIA
++ event->event_code = EVENT_LBUTTONDOWN;
++#else
+ if (ev.button.button == SDL_BUTTON_LEFT)
+ event->event_code = EVENT_LBUTTONDOWN;
+ else if (ev.button.button == SDL_BUTTON_RIGHT)
+@@ -878,18 +881,23 @@
+ #endif
+ else
+ break;
++#endif
+
+ fillMouseEvent(*event, ev.button.x, ev.button.y);
+
+ return true;
+
+ case SDL_MOUSEBUTTONUP:
++#ifdef QTOPIA
++ event->event_code = EVENT_LBUTTONUP;
++#else
+ if (ev.button.button == SDL_BUTTON_LEFT)
+ event->event_code = EVENT_LBUTTONUP;
+ else if (ev.button.button == SDL_BUTTON_RIGHT)
+ event->event_code = EVENT_RBUTTONUP;
+ else
+ break;
++#endif
+ fillMouseEvent(*event, ev.button.x, ev.button.y);
+
+ return true;
diff --git a/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/sword1.patch b/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/sword1.patch
new file mode 100644
index 0000000..0c934ef
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/sword1.patch
@@ -0,0 +1,16 @@
+--- ./sword1/sword1.cpp.old 2004-05-16 03:17:26.000000000 +0930
++++ ./sword1/sword1.cpp 2004-05-16 03:12:42.000000000 +0930
+@@ -1061,8 +1061,11 @@
+ _systemVars.runningFromCd = true;
+ _systemVars.currentCD = 2;
+ test.close();
+- } else
+- error("Unable to find files.\nPlease read the instructions again");
++ } else {
++ _systemVars.runningFromCd = false;
++ _systemVars.playSpeech = false;
++// error("Unable to find files.\nPlease read the instructions again");
++ }
+ }
+ }
+
diff --git a/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/tremor.patch b/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/tremor.patch
new file mode 100644
index 0000000..3acf302
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/scummvm-0.6.0/tremor.patch
@@ -0,0 +1,32 @@
+--- ./sound/vorbis.cpp.old 2004-05-16 04:23:59.000000000 +0930
++++ ./sound/vorbis.cpp 2004-05-16 04:24:23.000000000 +0930
+@@ -29,7 +29,7 @@
+ #include "sound/audiostream.h"
+ #include "sound/audiocd.h"
+
+-#include <vorbis/vorbisfile.h>
++#include <tremor/ivorbisfile.h>
+
+
+ AudioStream *makeVorbisStream(OggVorbis_File *file, int duration);
+--- ./configure.old 2004-05-16 04:46:47.000000000 +0930
++++ ./configure 2004-05-16 04:50:42.000000000 +0930
+@@ -560,15 +560,15 @@
+ if test "$_vorbis" = auto ; then
+ _vorbis=no
+ cat > $TMPC << EOF
+-#include <vorbis/codec.h>
++#include <tremor/ivorbiscodec.h>
+ int main(void) { vorbis_packet_blocksize(0,0); return 0; }
+ EOF
+ cc_check $LDFLAGS $CXXFLAGS $OGG_CFLAGS $OGG_LIBS $VORBIS_CFLAGS $VORBIS_LIBS \
+- -lvorbis -logg -lm && _vorbis=yes
++ -lvorbisidec -logg -lm && _vorbis=yes
+ fi
+ if test "$_vorbis" = yes ; then
+ _def_vorbis='#define USE_VORBIS'
+- LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisfile -lvorbis -logg"
++ LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS -lvorbisidec -logg"
+ INCLUDES="$INCLUDES $OGG_CFLAGS $VORBIS_CFLAGS"
+ else
+ _def_vorbis='#undef USE_VORBIS'
diff --git a/org.handhelds.familiar/packages/scummvm/scummvm-qpe_0.6.1b.bb b/org.handhelds.familiar/packages/scummvm/scummvm-qpe_0.6.1b.bb
new file mode 100644
index 0000000..82623d8
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/scummvm-qpe_0.6.1b.bb
@@ -0,0 +1,10 @@
+include scummvm.inc
+DEPENDS = "libsdl-qpe libmad tremor libogg zlib libmpeg2"
+
+S="${WORKDIR}/scummvm-${PV}/"
+
+do_compile() {
+ oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} -lmpeg2" \
+ DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DQTOPIA -DUSE_MAD -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2"
+}
+
diff --git a/org.handhelds.familiar/packages/scummvm/scummvm.inc b/org.handhelds.familiar/packages/scummvm/scummvm.inc
new file mode 100644
index 0000000..88c6f13
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/scummvm.inc
@@ -0,0 +1,29 @@
+DESCRIPTION = "Virtual Machine for LucasArts Adventures for Qt/Embedded based palmtop environments w/ SDL."
+SECTION = "games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/scummvm/scummvm-${PV}.tar.bz2 \
+ file://tremor.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--host=${HOST_SYS} \
+ --backend=sdl \
+ --with-sdl-prefix=${STAGING_BINDIR}/.. \
+ --disable-alsa \
+ --with-ogg-prefix=${STAGING_LIBDIR}/.. \
+ --with-vorbis-prefix=${STAGING_LIBDIR}/.. \
+ --with-mpeg2-prefix=${STAGING_LIBDIR}/.. \
+ --with-mad-prefix=${STAGING_LIBDIR}/.. "
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 scummvm ${D}${bindir}/scummvm
+}
+
diff --git a/org.handhelds.familiar/packages/scummvm/scummvm_0.6.0.bb b/org.handhelds.familiar/packages/scummvm/scummvm_0.6.0.bb
new file mode 100644
index 0000000..38f0c7e
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/scummvm_0.6.0.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Virtual Machine for LucasArts Adventures for Qt/Embedded based palmtop environments w/ SDL."
+SECTION = "opie/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe libmad tremor libogg zlib libmpeg2"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/scummvm/scummvm-${PV}.tar.bz2 \
+ file://sword1.patch;patch=1 \
+ file://tremor.patch;patch=1 \
+ file://mouse.patch;patch=1 "
+
+inherit autotools
+
+EXTRA_OECONF = "--host=${HOST_SYS} \
+ --backend=sdl \
+ --with-sdl-prefix=${STAGING_BINDIR}/.. \
+ --disable-alsa \
+ --with-ogg-prefix=${STAGING_LIBDIR}/.. \
+ --with-vorbis-prefix=${STAGING_LIBDIR}/.. \
+ --with-mpeg2-prefix=${STAGING_LIBDIR}/.. \
+ --with-mad-prefix=${STAGING_BINDIR}/.. "
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile() {
+ oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} -lmpeg2" \
+ DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DQTOPIA -DUSE_MAD -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 scummvm ${D}${bindir}/scummvm
+}
+
diff --git a/org.handhelds.familiar/packages/scummvm/scummvm_0.6.1b.bb b/org.handhelds.familiar/packages/scummvm/scummvm_0.6.1b.bb
new file mode 100644
index 0000000..6f805b6
--- /dev/null
+++ b/org.handhelds.familiar/packages/scummvm/scummvm_0.6.1b.bb
@@ -0,0 +1,10 @@
+include scummvm.inc
+DEPENDS = "virtual/libsdl libmad tremor libogg zlib libmpeg2"
+SRC_URI += " file://mouse.patch;patch=1 "
+
+do_compile() {
+ oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} -lmpeg2" \
+ DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DUSE_MAD -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2"
+}
+
+