summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/libidl
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/libidl
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/libidl')
-rw-r--r--org.handhelds.familiar/packages/libidl/libidl-native_0.8.3.bb5
-rw-r--r--org.handhelds.familiar/packages/libidl/libidl-native_0.8.6.bb5
-rw-r--r--org.handhelds.familiar/packages/libidl/libidl_0.8.2.bb10
-rw-r--r--org.handhelds.familiar/packages/libidl/libidl_0.8.3.bb23
-rw-r--r--org.handhelds.familiar/packages/libidl/libidl_0.8.6.bb23
5 files changed, 66 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/libidl/libidl-native_0.8.3.bb b/org.handhelds.familiar/packages/libidl/libidl-native_0.8.3.bb
new file mode 100644
index 0000000..bcc1ec6
--- /dev/null
+++ b/org.handhelds.familiar/packages/libidl/libidl-native_0.8.3.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+include libidl_${PV}.bb
+inherit native
+
+DEPENDS = "glib-2.0-native"
diff --git a/org.handhelds.familiar/packages/libidl/libidl-native_0.8.6.bb b/org.handhelds.familiar/packages/libidl/libidl-native_0.8.6.bb
new file mode 100644
index 0000000..bcc1ec6
--- /dev/null
+++ b/org.handhelds.familiar/packages/libidl/libidl-native_0.8.6.bb
@@ -0,0 +1,5 @@
+SECTION = "libs"
+include libidl_${PV}.bb
+inherit native
+
+DEPENDS = "glib-2.0-native"
diff --git a/org.handhelds.familiar/packages/libidl/libidl_0.8.2.bb b/org.handhelds.familiar/packages/libidl/libidl_0.8.2.bb
new file mode 100644
index 0000000..b8c5ec6
--- /dev/null
+++ b/org.handhelds.familiar/packages/libidl/libidl_0.8.2.bb
@@ -0,0 +1,10 @@
+LICENSE = "LGPL"
+SECTION = "libs"
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-0.8.2.tar.bz2"
+S = "${WORKDIR}/libIDL-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage () {
+ oe_runmake install DESTDIR="" bindir=${STAGING_BINDIR} includedir=${STAGING_INCDIR} libdir=${STAGING_LIBDIR} prefix=${STAGING_DIR}
+}
diff --git a/org.handhelds.familiar/packages/libidl/libidl_0.8.3.bb b/org.handhelds.familiar/packages/libidl/libidl_0.8.3.bb
new file mode 100644
index 0000000..5a6f580
--- /dev/null
+++ b/org.handhelds.familiar/packages/libidl/libidl_0.8.3.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Library for parsing CORBA IDL files"
+SECTION = "gnome/libs"
+DEPENDS = "glib-2.0"
+PR = "r1"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-${PV}.tar.bz2"
+S = "${WORKDIR}/libIDL-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install \
+ prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ infodir=${STAGING_INFODIR}
+}
+
+FILES_${PN} = "${libdir}/*.so.*"
+FILES_${PN}-dev += " ${bindir}"
diff --git a/org.handhelds.familiar/packages/libidl/libidl_0.8.6.bb b/org.handhelds.familiar/packages/libidl/libidl_0.8.6.bb
new file mode 100644
index 0000000..5a6f580
--- /dev/null
+++ b/org.handhelds.familiar/packages/libidl/libidl_0.8.6.bb
@@ -0,0 +1,23 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Library for parsing CORBA IDL files"
+SECTION = "gnome/libs"
+DEPENDS = "glib-2.0"
+PR = "r1"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-${PV}.tar.bz2"
+S = "${WORKDIR}/libIDL-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install \
+ prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ infodir=${STAGING_INFODIR}
+}
+
+FILES_${PN} = "${libdir}/*.so.*"
+FILES_${PN}-dev += " ${bindir}"