summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/libaal
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
committerRene Wagner <rw@handhelds.org>2006-05-13 15:42:03 +0200
commit5a5346dfbec459c10d9e61e16e125b83975a1ef1 (patch)
tree342e16f3fe790d03b93294344e6154459888939f /org.handhelds.familiar/packages/libaal
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e35772d79306d1d9de19c12b23681618532d.
Diffstat (limited to 'org.handhelds.familiar/packages/libaal')
-rw-r--r--org.handhelds.familiar/packages/libaal/libaal_1.0.4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/libaal/libaal_1.0.4.bb b/org.handhelds.familiar/packages/libaal/libaal_1.0.4.bb
new file mode 100644
index 0000000..e8956bd
--- /dev/null
+++ b/org.handhelds.familiar/packages/libaal/libaal_1.0.4.bb
@@ -0,0 +1,26 @@
+# This is the support library for reiser4progs, required when
+# building that package. The libraries from this build must
+# be installed on the system to use the reiser4progs programs
+PR = "r0"
+DESCRIPTION = "Library for user-level code accessing Reiser4 filesystems"
+HOMEPAGE = "http://www.namesys.com"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "base"
+LICENSE = "GPL-2"
+
+SRC_URI = "ftp://ftp.namesys.com/pub/reiser4progs/${P}.tar.gz"
+
+inherit autotools
+
+# This disables anything which uses libminimal - that library
+# is used for boot loader stuff and so is not required unless
+# the system will boot from a Reiser4 file system, the same
+# setting must exist for the reiser4progs build
+DISABLE_LIBMINIMAL ?= "--disable-libminimal"
+EXTRA_OECONF = "${DISABLE_LIBMINIMAL}"
+
+do_stage() {
+ echo "NOTE: stage package ${PF} is: (${PN},${PV},${PR})"
+ autotools_stage_includes
+ oe_libinstall -a -so -C src ${PN} ${STAGING_LIBDIR}
+}