summaryrefslogtreecommitdiff
path: root/org.handhelds.familiar/packages/jamvm/jamvm-native_1.4.2.bb
diff options
context:
space:
mode:
authorMika Laitio <lamikr@cc.jyu.fi>2006-11-09 02:46:03 +0200
committerroot <root@localhost.(none)>2006-11-09 02:46:03 +0200
commit215ddf4bdb36e53af313d662958bb94c30d91e48 (patch)
treeeae6d65a3260a624ff116b50e9d4b27458db18c3 /org.handhelds.familiar/packages/jamvm/jamvm-native_1.4.2.bb
parent8f99c2bd9da612062f74ea4b0e7d9b98a5821e59 (diff)
parentac111932d7503334362c08897599f25b8c82379c (diff)
Merge branch 'master' of http://familiar.handhelds.org/git/familiar-build into h6300_apm_fix
Diffstat (limited to 'org.handhelds.familiar/packages/jamvm/jamvm-native_1.4.2.bb')
-rw-r--r--org.handhelds.familiar/packages/jamvm/jamvm-native_1.4.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/org.handhelds.familiar/packages/jamvm/jamvm-native_1.4.2.bb b/org.handhelds.familiar/packages/jamvm/jamvm-native_1.4.2.bb
new file mode 100644
index 0000000..f972c9e
--- /dev/null
+++ b/org.handhelds.familiar/packages/jamvm/jamvm-native_1.4.2.bb
@@ -0,0 +1,25 @@
+# jamvm-native OE build file
+# Copyright (C) 2006, Rene Wagner. All Rights Reserved
+# Released under the MIT license (see org.handhelds.familiar/COPYING.MIT)
+
+include jamvm_${PV}.bb
+inherit native
+
+DEPENDS = "classpath-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz"
+
+prefix = "${STAGING_DIR}/${HOST_SYS}"
+EXTRA_OECONF = "--with-classpath-install-dir=${STAGING_DIR}/${HOST_SYS}"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/jamvm"
+S = "${WORKDIR}/jamvm-${PV}"
+
+do_stage() {
+ mkdir -p ${STAGING_BINDIR}
+ install -m 0755 src/jamvm ${STAGING_BINDIR}/
+
+ mkdir -p ${STAGING_DATADIR}/jamvm
+ install -m 0644 lib/inst_classes.zip ${STAGING_DATADIR}/jamvm/classes.zip
+}
+