aboutsummaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index ce66b21ab6..ecd4ef69b4 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -8,7 +8,6 @@ include(LLVMParseArguments)
# 'basename(test_dirname)Tests'.
function(add_clang_unittest)
parse_arguments(CLANG_UNITTEST "USED_LIBS" "" ${ARGN})
- set(LLVM_USED_LIBS ${CLANG_UNITTEST_USED_LIBS})
list(GET CLANG_UNITTEST_DEFAULT_ARGS 0 test_dirname)
list(REMOVE_AT CLANG_UNITTEST_DEFAULT_ARGS 0)
@@ -24,6 +23,7 @@ function(add_clang_unittest)
set(EXCLUDE_FROM_ALL ON)
endif()
add_clang_executable(${test_name}Tests ${CLANG_UNITTEST_DEFAULT_ARGS})
+ target_link_libraries(${test_name}Tests ${CLANG_UNITTEST_USED_LIBS})
add_dependencies(ClangUnitTests ${test_name}Tests)
set_target_properties(${test_name}Tests PROPERTIES FOLDER "Clang tests")
endfunction()