aboutsummaryrefslogtreecommitdiff
path: root/tools/clang-format/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/clang-format/CMakeLists.txt')
-rw-r--r--tools/clang-format/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/clang-format/CMakeLists.txt b/tools/clang-format/CMakeLists.txt
new file mode 100644
index 0000000000..c86a920841
--- /dev/null
+++ b/tools/clang-format/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(LLVM_LINK_COMPONENTS support)
+set(LLVM_USED_LIBS clangFormat clangTooling clangBasic clangAST)
+
+add_clang_executable(clang-format
+ ClangFormat.cpp
+ )
+
+target_link_libraries(clang-format
+ clangFormat
+ clangTooling
+ clangBasic
+ clangRewriteFrontend
+ )
+
+install(TARGETS clang-format
+ RUNTIME DESTINATION bin)
+