aboutsummaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2012-06-21 01:30:21 +0000
committerChandler Carruth <chandlerc@gmail.com>2012-06-21 01:30:21 +0000
commitb0d8671f95fe08a220118bca29063ba4d11a9dac (patch)
treecab72330a29dcc55d7c6f27692624f3e70469bd5 /unittests/CMakeLists.txt
parent7d96f6106bfbd85b1af06f34fdbf2834aad0e47e (diff)
Remove a goofy CMake hack and use the standard CMake facilities to
express library-level dependencies within Clang. This is no more verbose really, and plays nicer with the rest of the CMake facilities. It should also have no change in functionality. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@158888 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index ce66b21ab6..ecd4ef69b4 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -8,7 +8,6 @@ include(LLVMParseArguments)
# 'basename(test_dirname)Tests'.
function(add_clang_unittest)
parse_arguments(CLANG_UNITTEST "USED_LIBS" "" ${ARGN})
- set(LLVM_USED_LIBS ${CLANG_UNITTEST_USED_LIBS})
list(GET CLANG_UNITTEST_DEFAULT_ARGS 0 test_dirname)
list(REMOVE_AT CLANG_UNITTEST_DEFAULT_ARGS 0)
@@ -24,6 +23,7 @@ function(add_clang_unittest)
set(EXCLUDE_FROM_ALL ON)
endif()
add_clang_executable(${test_name}Tests ${CLANG_UNITTEST_DEFAULT_ARGS})
+ target_link_libraries(${test_name}Tests ${CLANG_UNITTEST_USED_LIBS})
add_dependencies(ClangUnitTests ${test_name}Tests)
set_target_properties(${test_name}Tests PROPERTIES FOLDER "Clang tests")
endfunction()