aboutsummaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-09-25 05:41:21 +0000
committerDouglas Gregor <dgregor@apple.com>2009-09-25 05:41:21 +0000
commit9773f6065b7bc0561430bba1bfb64db2cd7bee7e (patch)
tree3475e0df0f82261a9744d76f718680b8c88046be /tools/CMakeLists.txt
parenta24563abb0387c63c428ef7243619fdab7ff2f07 (diff)
Hide clang-wpa executable behind a CMake variable so it won't be built by default
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@82751 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 74a810ce35..91039e05df 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,4 +1,7 @@
add_subdirectory(clang-cc)
add_subdirectory(driver)
add_subdirectory(index-test)
-add_subdirectory(wpa)
+option(CLANG_BUILD_EXPERIMENTAL "Build experimenal Clang tools" OFF)
+if (CLANG_BUILD_EXPERIMENTAL)
+ add_subdirectory(wpa)
+endif ()