aboutsummaryrefslogtreecommitdiff
path: root/lib/Tooling/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2012-05-23 16:29:20 +0000
committerManuel Klimek <klimek@google.com>2012-05-23 16:29:20 +0000
commitf9d4cbd3dd1eb4cf3ec3c5ec7acc310415beeefd (patch)
treedffb41d898c7bfccdfec35593e7d8e794479f2c5 /lib/Tooling/CMakeLists.txt
parent703b6015176550eefc91f3e2f19cd19beacbc592 (diff)
Adds the Refactoring library, which is a layer on top of the Tooling library
that allows easy refactoring across translation units. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@157331 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Tooling/CMakeLists.txt')
-rw-r--r--lib/Tooling/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/Tooling/CMakeLists.txt b/lib/Tooling/CMakeLists.txt
index 66045515e5..aada61714d 100644
--- a/lib/Tooling/CMakeLists.txt
+++ b/lib/Tooling/CMakeLists.txt
@@ -1,8 +1,9 @@
set(LLVM_LINK_COMPONENTS support)
-SET(LLVM_USED_LIBS clangBasic clangFrontend clangAST)
+SET(LLVM_USED_LIBS clangBasic clangFrontend clangAST clangRewrite)
add_clang_library(clangTooling
CompilationDatabase.cpp
+ Refactoring.cpp
Tooling.cpp
ArgumentsAdjusters.cpp
)