aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2012-12-18 19:39:40 +0000
committerDouglas Gregor <dgregor@apple.com>2012-12-18 19:39:40 +0000
commita34173e6783f8334b3a120131adba7d3f6c6509f (patch)
tree6ab31d4e6f790a041866b8bf159e18be5471c06c /CMakeLists.txt
parent6bd120387a0d36bb5a748d4100b3eaa399eb53c5 (diff)
CMake: Make sure to detect LibXml2 when Clang is built standalone
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@170444 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7099ac765..0ad0557420 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,11 @@ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )
set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib )
set( CLANG_BUILT_STANDALONE 1 )
+
+ find_package(LibXml2)
+ if (LIBXML2_FOUND)
+ set(CLANG_HAVE_LIBXML 1)
+ endif ()
endif()
set(CLANG_RESOURCE_DIR "" CACHE STRING