aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-03-26 16:11:33 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-03-26 16:11:33 +0000
commit48e36464eebff28bd08793d1c3570c10bf3a59e7 (patch)
tree8bd1b91bcbaf1ff90151a63423d89cb89bc29071 /CMakeLists.txt
parent65b427f96821b7ba0646a40979059573faf25040 (diff)
Removed workaround for unspecified build problem on MinGW.
Tested that MinGW/MSYS builds fine without that. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@128341 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ebe3c4f60..a56d07488d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -182,11 +182,9 @@ macro(add_clang_library name)
if (LLVM_COMMON_LIBS)
target_link_libraries(${name} ${LLVM_COMMON_LIBS})
endif()
- if( NOT MINGW )
- get_system_libs(llvm_system_libs)
- if( llvm_system_libs )
- target_link_libraries(${name} ${llvm_system_libs})
- endif()
+ get_system_libs(llvm_system_libs)
+ if( llvm_system_libs )
+ target_link_libraries(${name} ${llvm_system_libs})
endif()
add_dependencies(${name} ClangDiagnosticCommon)
if(MSVC)