aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2009-11-17 09:32:51 +0000
committerDaniel Dunbar <daniel@zuster.org>2009-11-17 09:32:51 +0000
commit45088e2afdd561153e9ceadba7ce34c366f3db2e (patch)
treeeb8b8dad569d1c36af16da0cdb435cc0d482a7d6 /CMakeLists.txt
parenta51ca5221235325ac420954a357db19290b8f93a (diff)
Add optional CMake build for Clang examples, patch by Kovarththanan Rajaratnam.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@89078 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f4ab33b33..9e84d94a3b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,6 +94,11 @@ install(DIRECTORY include/
add_definitions( -D_GNU_SOURCE )
+option(CLANG_BUILD_EXAMPLES "Build CLANG example programs." OFF)
+if(CLANG_BUILD_EXAMPLES)
+ add_subdirectory(examples)
+endif ()
+
add_subdirectory(include)
add_subdirectory(lib)
add_subdirectory(tools)