aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Rose <jordan_rose@apple.com>2013-02-08 01:42:37 +0000
committerJordan Rose <jordan_rose@apple.com>2013-02-08 01:42:37 +0000
commit3092d9da06b7f9e57fde580330727eba125580bf (patch)
treed6805778131e19cdeff4e7ea58f696542808458e /CMakeLists.txt
parenta69a58991fdf67d6d26aff9028ced102142bfcc6 (diff)
CMake: Optionally allow running the Clang unit tests in standalone builds.
The reason this is not enabled by default is because there is no way for Clang to guarantee that the LLVM unit testing infrastruture has been built. However, if it /has/ been built, there's no reason why the standalone Clang build can't use it! This should have no effect on existing builds -- in a combined build the value of the CLANG_INCLUDE_TESTS option defaults to the LLVM equivalent, and in a standalone build it defaults to off. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@174691 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ad0557420..d1c8cec176 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -279,10 +279,17 @@ add_subdirectory(examples)
# TODO: docs.
add_subdirectory(test)
-if( LLVM_INCLUDE_TESTS )
- if( NOT CLANG_BUILT_STANDALONE )
- add_subdirectory(unittests)
- endif()
+option(CLANG_BUILD_TESTS
+ "Build Clang unit tests. If OFF, just generate build targets."
+ LLVM_BUILD_TESTS)
+option(CLANG_INCLUDE_TESTS
+ "Generate build targets for the Clang unit tests."
+ LLVM_INCLUDE_TESTS)
+
+if( CLANG_INCLUDE_TESTS )
+ add_subdirectory(unittests)
+elseif( CLANG_BUILD_TESTS )
+ message(FATAL_ERROR "CLANG_BUILD_TESTS requires CLANG_INCLUDE_TESTS")
endif()
# Workaround for MSVS10 to avoid the Dialog Hell