aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 692c8b0..3176a1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,7 @@
AC_INIT([cpuminer], [0.8.1])
AC_PREREQ(2.52)
+AC_CANONICAL_SYSTEM
AC_CONFIG_SRCDIR([cpu-miner.c])
AM_INIT_AUTOMAKE([gnu])
AC_CONFIG_HEADERS([cpuminer-config.h])
@@ -20,12 +21,19 @@ AC_CHECK_HEADERS(syslog.h)
AC_FUNC_ALLOCA
-case $host in
+case $target in
*-*-mingw*)
+ have_x86_64=false
have_win32=true
PTHREAD_FLAGS=""
;;
+ x86_64-*)
+ have_x86_64=true
+ have_win32=false
+ PTHREAD_FLAGS="-pthread"
+ ;;
*)
+ have_x86_64=false
have_win32=false
PTHREAD_FLAGS="-pthread"
;;
@@ -37,6 +45,7 @@ AC_CHECK_LIB(pthread, pthread_create, PTHREAD_LIBS=-lpthread)
AM_CONDITIONAL([WANT_JANSSON], [test x$request_jansson = xtrue])
AM_CONDITIONAL([HAVE_WINDOWS], [test x$have_win32 = xtrue])
+AM_CONDITIONAL([HAVE_x86_64], [test x$have_x86_64 = xtrue])
if test x$request_jansson = xtrue
then