aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArt Forz <artforz@localhost>2011-10-01 13:20:36 +0200
committerArt Forz <artforz@localhost>2011-10-01 13:20:36 +0200
commit383482e0a6dc7548298757e32cb78d94e06dc20d (patch)
treea01ff738b90d151b8ee86288ed18c80c30cd034a /configure.ac
parentf4fdf27b6c44db4e27e74a6504c4e599ff642b2a (diff)
Rip out sha256 algos
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 0 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index 1747aef..3b0733f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,42 +54,6 @@ else
JANSSON_LIBS=-ljansson
fi
-dnl Find YASM
-has_yasm=false
-AC_PATH_PROG([YASM],[yasm],[false])
-if test "x$YASM" != "xfalse" ; then
- AC_MSG_CHECKING([if yasm version is greater than 1.0.1])
- yasmver=`yasm --version | head -1 | cut -d\ -f2`
- yamajor=`echo $yasmver | cut -d. -f1`
- yaminor=`echo $yasmver | cut -d. -f2`
- yamini=`echo $yasmver | cut -d. -f3`
- if test "$yamajor" -ge "1" ; then
- if test "$yamajor" -eq "1" ; then
- if test "$yaminor" -ge "0" ; then
- if test "$yaminor" -eq "0"; then
- if test "$yamini" -ge "1"; then
- has_yasm=true
- fi
- else
- has_yasm=true
- fi
- fi
- fi
- else
- has_yasm=false
- fi
- if test "x$has_yasm" = "xtrue" ; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- fi
-fi
-if test "x$has_yasm" = "xfalse" ; then
- AC_MSG_NOTICE([yasm is required for the sse2_64 algorithm. It will be skipped.])
-fi
-
-AM_CONDITIONAL([HAS_YASM], [test x$has_yasm = xtrue])
-
PKG_PROG_PKG_CONFIG()
LIBCURL_CHECK_CONFIG(, 7.10.1, ,
@@ -103,7 +67,6 @@ AC_CONFIG_FILES([
Makefile
compat/Makefile
compat/jansson/Makefile
- x86_64/Makefile
])
AC_OUTPUT