aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorfleger <florian6.leger@laposte.net>2011-04-11 13:04:29 -0400
committerJeff Garzik <jgarzik@pobox.com>2011-04-11 13:04:29 -0400
commita9a2840d8198e45a990519431aa26586bbac8932 (patch)
tree6b43dca7b3652c724c3c29f87db6ba367cbdb678 /Makefile.am
parent1a16f2ae63fa1fad8d3069db100149eb6d236d82 (diff)
Proper platform detection.
Use target instead of host. Fix compilation for non win32 and non x86_64 platforms.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 04a45da..4d4f2bb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,8 +20,7 @@ minerd_SOURCES = elist.h miner.h compat.h \
minerd_LDFLAGS = $(PTHREAD_FLAGS)
minerd_LDADD = @LIBCURL@ @JANSSON_LIBS@ @PTHREAD_LIBS@
-if HAVE_WINDOWS
-else
+if HAVE_x86_64
if HAS_YASM
SUBDIRS += x86_64
minerd_LDADD += x86_64/libx8664.a