aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Garzik <jeff@garzik.org>2010-11-26 16:13:32 -0500
committerJeff Garzik <jgarzik@redhat.com>2010-11-26 16:13:32 -0500
commit4575851ea331ea85946c30421541a493c6659445 (patch)
treed71f52e1328b2db7f39102bdf2fdfca99d8d31e6 /Makefile.am
parent750deb7a9912af13a83f737753fac24dc4dc5bd8 (diff)
Build jansson 1.3 in-tree, if not present on system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 585e89e..299787e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,13 @@
-INCLUDES = -pthread -fno-strict-aliasing
+if WANT_JANSSON
+JANSSON_INCLUDES= -I$(top_srcdir)/compat/jansson
+else
+JANSSON_INCLUDES=
+endif
+
+SUBDIRS = compat
+
+INCLUDES = -pthread -fno-strict-aliasing $(JANSSON_INCLUDES)
bin_PROGRAMS = minerd